Help and advice please - Software updates


(Tom Phillips) #1

I reported a problem with RW 7.3.1 a few weeks back, which was confirmed as a bug. An update has been issued, I know, but I’ve been away from home and not yet able to upgrade to whatever the latest version currently is. When I tried to do that today, I was met with a problem I simply cannot solve.

The “Rapidweaver 7” icon now sits in the dock on my iMac with a question-mark on it. It won’t open when clicked. The pop-up menu offers the master file for my site and the backup, but neither of these will respond when clicked either.

My first thought was to go to Finder and open the site for editing from there. I was expecting this would begin by offering me the opportunity to upgrade to the latest RW release. However, the master version of the site AND the backup file which were last saved using RW 7.3.1 now appear in Finder with the file type shown as “Package” (I’ve not seen that before) and when clicked, they ask me what application I want to use to open them. The list offered includes RW 7.3.1 but again, I get no response.

Is it a simple case of downloading the very latest RW version and opening my RW 7.3.1 versions, or do I need to be doing something fancier than that? I cannot afford to have lost these files, so, advice, please.

Tom


(Tom Phillips) #2

OK, to move this forward, and because I’d had problems with RW 7.3.1, I downloaded a copy of RW 7.2.2 from the RW web site. This was the last completely stable version I’d used. I’ve been able to get my saved RW files to open successfully on this version, which is at least some relief. They appear to function normally and I can update my site.

I then used the Rapidweaver menu option to “Check for Updates”, thinking that this would offer me the chance to update to the latest, hopefully stable version of RW. However, instead, I got a message saying:

“Update Error
RapidWeaver can’t be updated when it’s running from a read-only volume like a disk image or an optical drive. Move RapidWeaver to your Applications folder, relaunch it from there, and try again.”

Why have I suddenly apparently found myself with a “read only” copy that I can’t update?

Tom


(Brian Vince) #3

I am currently using 7.3.3 and it has been pretty stable for me.

I have had the error message you mention before, it seems to happen when you get the RW app in a folder other than the application root folder … I simply moved the .app file from the subfolder to the application folder … that fixed it for me.


(Tom Phillips) #4

Thanks. Got it.

I thought the .app file was in the Applications folder, and indeed, there was one there. However, it appears that what was opening was the version in the Downloads folder, which I hadn’t yet deleted. Now that I’ve deleted it, I can upgrade.

Phew.

Tom