Help requested: can't check for RW updates in V7.1.7


(Charles Lamprey) #1

Purchased V7.1.7 today. After installing, I tried executing the menu item: “Rapidweaver 7” -> “Check for updates…”. I get an error dialog box in response:

Update Error!
“RapidWeaver can’t be updated when it’s running from a read-only volume like a disk image or an optical drive. Move RapidWeaver to your Applications folder, relaunch it from there, and try again.”

Note:

  • that I am NOT running from a read-only volume,
  • that Rapidweaver 7 is in my Applications folder,
  • that Rapidweaver 6 (in the same Applications folder on the same volume) performs the update check properly, and
  • that I am running MacOS sierra.

(Mark Sealey) #2

Charles,

What happens if you restart your machine - just in case the RW installer process is still trying to run from that r/o volume to which it actually probably was downloaded?


(Charles Lamprey) #3

Mark,

Thanks for the suggestion. I tried rebooting (no joy). Then, I reinstalled RW 7 and that seemed to fix the issue.

Chuck


(Mark Sealey) #4

Charles - I’m sure you’d considered that. Sometimes the paths to distribution files gets fixed. Glad you got it working :slight_smile: