Homepage wont update

Hey everyone. I just updated my contact info in the footer and added a privacy pop up (mini cookie stack) and for some reason every page on my website has updated except the home page. Any ideas?? Also anyone know when iNsta stack will be working again?

Possibly, your stack may have changed the page extension from HTML to PHP. Check your Rapidweaver page details and see if its PHP or HTML and then log into your web host control panel and check whether there are both HTML and PHP files for your homepage and delete the outdated one (usually the HTML one).

The iNsta Stack is still for sale so that would be a question for @weaver to answer. I know Instagram ‘broke’ most of the Instagram stacks out there a while ago. I see it’s not working on Weaverthemes own demo page any more. iNsta - RapidWeaver Stack

rapidweaver informed me earlier that there were two index files and I deleted the html one (prior to posting this). I just checked and its still gone. I have tried re-publishing my whole site and it still wont update my homepage. Any other ideas? Thanks so much!

This isn’t a MiniCookie stack problem. Looks like either your web server is misconfigured or you accidentally deleted something you shouldn’t have. Because I cannot get your website to load at all, at this end:

As I’ve said on my website, lots of stacks use .php extensions. These work to apply a ‘flag’ on the page and tell the web server there is possibly some PHP code in there that needs to be processed, before the page is served. Very simple and harmless.

I suspect you accidentally had both old .html and new .php pages published to the same directory. Now you have deleted both or renamed them to something else and broken the website. Hence the ‘Internal Server Error’.

All you have to do is login via FTP or your website file manager and delete any duplicate .html pages you see in your website.

Thanks for the response. I have doublechecked by logging in and using the file manager and there is only the 1 index.php showing an update from this morning. BUT it still hasnt updated the footer and the mini cookie stack. Ive tried again to re-publish all files but its still not working. when i logged into our hosting account i did get an error that i was using old php, 5.6 so i updated it to 7.4. since it still wasnt working i tried all versions offered, 7.3, etc and still nothing. Any other ideas would be greatly appreciated. Thanks!

Only use a supported version of PHP on a public-facing website:
https://www.php.net/supported-versions.php

Perhaps speak with the support department at your hosting company and get them to check your website from their end.

Thanks for the tip, i reached out to our hosting company and they were able to correct it. apparently it was incorrect permission set on the main folder. and they updated the php on their end.