Site page will not update when published


(Ruthanne Holbert) #1

My site is published and I’ve made a few changes since that were easily updated online. After adding a new stack to a page, however, the changes will not publish on that single page . It is the only one where all the stacks are now index.php instead of index.html. When I change the name under general settings to html they revert right back to php. Is this why the page will not publish? Please assist.

Thank you.


(NeilUK) #2

It’s possible that the old html file is still on the server. RapidWeaver doesn’t delete files from the server so if you originally had a page that was html, then updated it to php, the old html file will probably be the reason you’re not seeing the updates.

You’ll need to check the files on the server to see if there’s an html and php file for the page in question. But be careful not to delete the wrong one/s.


(Mathew Mitchell) #3

Do you mean you can’t see the difference in the published page? (I think this is the case.) OR do you acdtually mean RW does not publish the page and the little “dot” does not go away?

Assuming it’s the first situation, you keep getting the PHP name on your file because you are using some stack (there’s quite a few that could do this) that NEED PHP in order to run properly. In these cases yu will end up with an index.PHP file on your server: as is intended. (And as noted by @NeilUK.) For example several email stacks will require PHP. But it’s not only email stacks: there’s a fairly wide variety of stacks that require PHP. Enough that I just create all my new pages as INDEX.PHP!

In this case go in via an FTP app such as Cyberduck, Transmit, and a number of others and remove the offending extra file. In the vast majority of cases with hosts you can also do this using the web-based cPanel your host provides. You want the index.php file to remain, and the index.html on to be deleted.


(David) #4

I had a problem like this a few weeks ago. For me, the issue was cached pages. If you have the Develop menu (in Safari, set that in its preferences). In Develop, empty caches, then restart the browser.


(Ruthanne Holbert) #5

Thank you all for these helpful suggestions. I did try these suggestions such as clearing the caches, yet nothing has worked. So I had my site taken down so I could reload my entire site since everything worked perfectly when it was first launched. However, now publishing won’t work.
Although I went over the current publishing info with my host site, I continually get the message that my Rapidweaver file cannot publish to my FTP server. My host site doesn’t have any answers in this regard. I tried several times to download my site file to my desktop so I could drop it into my
Cpanel folder, however, the program freezes up and won’t download. Thank you all again for your input.


(Ruthanne Holbert) #6

I was online with my hosting site and we finally determined what the problem was. Although all my publishing info is current and correct, not any of my Rapidweaver files are going to the right server address or FTP. They are going somewhere else. My entire site is down in an effort to relaunch. Now I need to know how to correct this misdirection within the program itself evidently, because it is not something to do with a particular file having an issue. My internal connection works with my host, but not the external connection. I found some things to try in the manual, however, they did not work. I may need to rebuild my entire site in another program if I can’t figure this out. Thank you to those who have assisted!


(Jan Fuellemann) #7

You can specify the path in the publishing setup.


(Ruthanne Holbert) #8

Thank You. Yes. I have all the publishing info correct. The site was taken completely down in trying to relaunch and now goes to the wrong address that is only evident in advanced settings. The message appears: Couldn’t start the internal web server on 127.0.0.1:21 permission denied.
Somehow I need for the program to know where to go because the info on every RW file is correct. It still will not connect to the right FTP hosting site server. However, I appreciate your helpful response. Thank You.


(Don H) #9

Can you post a screenshot of the publishing settings? Blank out the password.


(scott williams) #10

What happens if you try a new project with just a single test page?

That will tell you if it’s an issue with the project itself ( I doubt it but easy to find out)


(Ruthanne Holbert) #11

Yes I have with several file projects. None of them connect although the publishing info is correct. Regardless of the file RW is not connecting externally to my hosting site. It goes here: 127.0.0.1:21 permission denied and not to the IP address I have correctly placed in publishing.

![41%20PM|690x431]


(Don H) #12

Can we see the error when you try to publish?

I can’t figure out why if you’re connecting to a server via an IP address you’re ending up with a login error from your local loopback (127.0.0.1) address. There is some sort of a routing issue.

Have you ever edited your hosts file? It seems like it was edited so that that IP address points to your local computer.

Can you open Network Utility and on the Ping tab, ping the address: 107.180.44.217 and post the results?

Also, on the Traceroute tab, run a trace route to that IP and post those results too?


(Ruthanne Holbert) #13

Thank You Don! It was an issue with the IP address not being recognized, and it has been resolved by assigning the destination again. I assumed it was in place to begin with, as it was provided in the publishing info, and did not say ‘undetermined destination.’ My site has uploaded! Now I just need to get the RW email form to work and I’ll be good :slight_smile: Thanks everyone for your help as it allowed me to narrow down the issue.


(Ruthanne Holbert) #14

Hello Don,
Shortly after my last post, I ran into another problem somewhat like the previous one.
Although my publishing info is correct and tests successfully, the individual pages of my site file will not show up visibly. Only a white screen appears on each of them with the message: Couldn’t start the internal web server on 127.0.0.1:21 permission denied. I have followed your instructions so you can see the results of tracing the route. I really appreciate any assistance you may give me. Much Thanks!

![56%20PM|396x500]


(Ruthanne Holbert) #15

Here is the traceroute also:


(Ruthanne Holbert) #16

Also here is what my home page for rapidweaver file looks like which won’t allow me to update changes to my site.


(Don H) #17

Can you explain what you did to resolve this? Where did you assign this address?

You really shouldn’t really have had to do any of this, so it’s puzzling why you needed to assign a destination for that IP address.

When do you get that error you posted in the RW screenshot? When you hit publish? When you preview?


(Ruthanne Holbert) #18

If you look at the top screenshot in this feed of the publishing page, you’ll see on the top left corner the word metatron.love . That was not supposed to be there. The IP address was supposed to be there, so when I simply tried selecting it and replacing it with the IP, it then showed up in that place and also underneath the publishing button on the top right. It then worked and I published my site.
Now that I want to make changes on specific pages what I see in my RW file is the last screen shot I have in this feed.
You’ll notice that the correct IP address is under the publish button and when I test connection on the publishing page it is successful.
However, the message 'couldn’t start the internal web server…is what I see now when I go into individual pages. I’m puzzled and at a loss. I spoke to my hosting people and everything is fine on their end.


(Don H) #19

Please post a new screenshot of your current publishing settings. The text/IP area you refer to in the screenshot is just the name of that publishing destination (you can have several different ones setup). It should have no effect at all on your.

It sounds like you are now having an issue with Preview in RW and not publishing.

Please post your the general section of the settings area?


(Ruthanne Holbert) #20