How can I add jQuery


(Andreas Belivanakis) #1

How can I add jQuery to a Rapidweaver project?

A developer believes that problems I’ve been having are due to jQuery not loading. I have uploaded my projects with the “Republish All Files” option several times to no avail.

How can I upload jQuery myself, manually to the project?
Where do I find the correct version for Rapidweaver? Which version is that?
Where does it need to be uploaded in the directory structure?
Are there any calls that have to be made/added to the project to make sure jQuery does load?

I understand that jQuery is supposed to upload automatically as I upload my projects, and load automatically as a website loads in the browser, but this apparently is not happening, and I am so frustrated, have wasted so much time, and am so desperate, I am willing to try anything at this point. Please help.


(Andreas Belivanakis) #2

This is what has been happening:


(Jannis from inStacks Software) #4

Your html file has a lot of generation errors, especially in the sidebar and extra content areas?

What are you doing there?


(Andreas Belivanakis) #5

On the home page, I have this code in the sidebar:

@import((sb))

<div id="myExtraContent4">@import((ec4))</div>

The first line brings over the sidebar content. The 2nd line adds the language flag buttons in ec4.

PlusKit does the job in both instances. However, it has stopped working in bringing in the freestyle banner and the hvslider background slideshow, so I had to delete the @import function and copy-paste the freestyle banner AND the hvslider background slideshow on each and every page, but only the freestyle banner now works.

The hvslider background slideshow works fine in Rapidweaver, but it doesn’t come up when published. Of course I have republished all files, several times, and made sure I have no index.php - index.html conflicts.


(Rob D) #6

This probably isn’t the answer you were waiting for, but I think there is an incompatibility somewhere. Maybe between your macOS and RW and maybe it’s an old hvslider. I’m sure you know that if you use High Sierra, the only version of RW that is compatible is 7.5.

Personally, I would replace the hvslider with some newer kind of stack (if only for testing) before I do anything else. Henk is out of stacks/themes business for some time now. His products were taken over by @willwood.


(Andreas Belivanakis) #7

I am aware of all that, but the thing is, there isn’t anything else that works with that theme for a background slideshow.

Besides, it worked fine up until recently. Still High Sierra, same Rapidweaver 7.5 version, same hvslider version, same everything.

Now, EVERY project I open up and do some work on, the moment I re-upload it, the background slideshow stops working. I am scared to open up any project now, because I know I will be faced with a non-functioning background slideshow.


(Jannis from inStacks Software) #8

Is it true that you try to use @import for importing a stacks page? Don’t do that but use partials.


(Jason Bostick) #9

You’re not using cloudflare or something are you? Have you tried uploading with an FTP client? You just have a ton of 404 errors - it seems like important files aren’t getting uploaded…

Also, if this is the theme you’re using: https://www.themeflood.com/xxl2r/ it appears that you may have quite an older version. Also, Will appears to have an updated HV Slider (see about halfway down this page: https://stacks4stacks.com/tsoojmedia/).

You might want to check in with WIll and see what you can update


(Andreas Belivanakis) #10

Thanks, but I’ve been using PlusKit for a very long time, and am comfortable with it.

Remember, the projects worked fine just a few days ago. The problems started after a restore I performed, but I have not changed anything. Rapidweaver was downloaded from scratch and installed with the serial number from the beginning, and all auxiliary files were copied over from the backup. None of the settings were copied over. I meticulously re-created all settings from scratch, including entering the serial numbers of all plug-ins.

In addition, the project seems to work perfectly in Rapidweaver. It is after publishing that the background slideshow fails to show up.


(Andreas Belivanakis) #11

No, no cloudflare used at all.

You may have encountered 404 errors because I’ve been re-uploading the project all day long.

I will check on the versions of the theme and hvslider, but I believe I had the latest versions. Besides, the projects worked fine just a few days ago. The problems started after a restore I performed, but I have not changed anything. Rapidweaver was downloaded from scratch and installed with the serial number from the beginning, and all auxiliary files were copied over from the backup. None of the settings were copied over. I meticulously re-created all settings from scratch, including entering the serial numbers of all plug-ins.

In addition, the project seems to work perfectly in Rapidweaver. It is after publishing that the background slideshow fails to show up.


(Jannis from inStacks Software) #12

Don’t get me wrong, but you are stating you restored and did several steps to re-create the project… you changed everything at the end :wink:


(Andreas Belivanakis) #13

I restored, yes, but did not change the themes, theme styles, etc. I downloaded and installed Rapidweaver from scratch. I even created all settings from scratch, not just Rapidweaver’s but the OS’s as well.

The only thing I had to do with the project was to re-enter the password. I changed nothing else, initially, but once I noticed the hvslider background slideshow and the freestyle banner were not displaying, I had to make changes. Specifically, I stopped using PlusKit and instead brought both the freestyle banner AND the hvslider directly into each page.

This resulted in the freestyle banner displaying, but the hvslider background slideshow still fails to show up.

Will seems to believe this is a jQuery not loading issue. Please see attached image on my second post. Therefore, my question is specifically centered on how to make jQuery work.


(Andreas Belivanakis) #14

BTW, I did check both the XXL2-r theme and the hvslider. The theme has not been updated for 2 years, and I know I have the latest version.

Ditto for hvslider. All attempts to install the latest version 1.1.2 resulted in a duplicate version warning from Rapidweaver.


(Andreas Belivanakis) #15

If a lot of people experience the same problem, there is usually a lot of attention, and a quick fix.

When I am the only one having a problem, however, that is, when I need help the most, then it seems I am on my own. It’s sad, but true.


(Will Woodgate) #16

Commonly if you are seeing a difference between RapidWeaver preview and the published website, that indicates the site has not correctly published.

Alternatively you might still be looking at an older cached version of the website or a browser extension (like an ad-blocker or similar) might be causing some blockage / breakage of the page.

You can also ALT + CMD + P in RapidWeaver to view the ‘preview’ in a web browser before publishing your website. Safari and RapidWeaver both use the same rendering engine (WebKit) so you should not be seeing any difference between those two.

I don’t know where you are getting that information from, but you are wrong. XXL was last updated 7th November 2017 and that information shown on the website is correct. And there is another update in the works right now, as I’ve alluded towards on another forum thread.

Other themes in the XXL series like XXL-v2, XXL-r, XXL-Flickr etc. are all discontinued and no longer actively receiving support or updates. They have not been available for a considerable length of time. These were developed by Henk Vrieselaar, not by myself. Henk has now retired from RapidWeaver development.

The hvslider stack was replaced last summer with the ‘Henk’s Slider’ stack. Both Henk’s Slider stack and XXL 4.0 are working fine for myself and other people.

So the way I see it, your options going forward are:

  1. Continue to troubleshoot why your publishing is not working and / or the difference between RapidWeaver preview and your web browser
  2. Open the theme index.html and try to update some of the jQuery calls yourself, to try a newer version of jQuery. All themes are opensource and can be edited. Lots of theme modification info is already posted online
  3. Hire an expert to oversee the above, to update this old theme for you and troubleshoot the slider (and possibly fix other things that require updating to improve the longevity)
  4. Update to a newer, officially supported version of XXL + ‘Henk’s Slider’ stack. The latest version works great for the rest of us and is a free update for existing users
  5. Cut your losses, abandon it, and build your website using another theme and / or background slider of your choice

(Andreas Belivanakis) #17

Will, thank you for your thorough reply.

I need to emphasize that the problem has been happening with all my projects, apparently all themes, not just with the XXL2 theme.

A nearly identical project to the problematic project was published with all slideshows working. I have no idea how and why. All other projects have their slideshows (freestyle2, superflex3, hvslider, bgStretcher2) fail upon publishing.

Adding the jQuery file to the index_files folder is a patch, not a long-term solution, and it only works for the home page, not on any other page.

I am glad the XXL theme has been upgraded to v. 4.0. I do not believe the problem is related to the version of the theme(s) as all my projects using all kinds of themes have been working fine up until recently, but where can I download the latest version?


(Will Woodgate) #18

If it can be replicated with other RapidWeaver addons too (not just isolated to XXL) then have you opened a support case with Realmac Software or spoken with the web hosting company to discuss where the publishing might be failing?

All the stacks you list are sliders that use jQuery Javascript. Normally the Stacks plugin adds the required jQuery calls for you. But there is a small possibility that an ISP might (for some unknown reason) decide to block these. In the Stacks settings you can choose to use locally hosted versions of jQuery and other libraries yourself. See if that makes any difference.

Update info for the theme is presented on the product page here:
https://themeflood.com/xxl
and
http://themeflood.com/knowledgebase/updating-themes

I have searched through my support emails and cannot find anybody else with similar issues. Most of the time when people report a difference between RapidWeaver preview and their published site, it is nearly always a result of caching. So I don’t currently have any further ideas to help.


(Andreas Belivanakis) #19

This has been by far the most helpful suggestion I’ve received thus far.

jquery-stacks

Checking the two jQuery boxes in Stacks prefs made the difference IMMEDIATELY on an under construction page using Superflex 3 as the slideshow stack:

www.milosgreece.net

Now, I have yet to test it on my other projects, so I will refrain from declaring this as the ultimate solution yet. Besides, all my projects worked fine before without these features enabled, so the culprit must be somewhere else.

But having said all that, this solution worked at least on this project, and is thus a good start. Thanks a lot!


(Andreas Belivanakis) #20

I purchased Waterfall thinking it would help me with automatic updating of my themes. Keep dreaming, Andreas!

This is the disaster known as Waterfall. For practically every theme, “Remote version information is not available. Please contact developer for details”.

What to do?


(Will Woodgate) #21

Obviously update checking does not work for free demo versions of themes (that is one of the limitations imposed). Nether will update checking work for themes you duplicate / rename. If a theme company changes name or ownership, then equally that may also mean updates can’t be located.

For other themes, automatic update checking requires that the theme contains the necessary links and other meta data required to securely talk with the appcast server and compare the version numbers. Ultimately themes released before Waterfall was even proposed or developed are not going to include this information. So for the first time, you will have to manually download and install Waterfall-compatible themes. From then on, they will be able to check for updates.

I’m sure others on these forums will back me up in saying that once you are at the point of installing Waterfall compatible themes, it is a valuable addon that does a very good job of keeping track of theme updates. Just because you cannot understand or get it to work in the first instance does not mean it is a “disaster”. Most theme developers support Waterfall + RW7 update checking.