Image not displayed in home page


(Andrea) #1

I cannot see the images in my home page. All the images in the other pages works ok.

Forbidden
You don’t have permission to access /files/rah_29683400842.jpg on this server.

I can see them in preview but not in the published site. I re-publish all files without success.
I’ve read that can be a permiss problem…but what I can do?
thank you


(Mark Sealey) #2

Yes, this looks like a permissions fault, as you surmise.

If you have access to an FTP client like Transmit you should be able to log in to your server and inspect the file’s permissions. They should be 755.


(Andrea) #3

Thanks for your help.
I use FileZilla for ftp. But I don’t known where to go for change the permiss to 755.


(Mark Sealey) #4

Andrea,

It’s been a while since I used FileZilla. But it looks from this grab as though there is a dropdown with ‘File Attributes’. If I’m wrong, a quick search on Google (I entered’filezilla changing permissions’) should allow you to do so. Good luck!


(Andrea) #5

Thanks Mark, I change all the permiss in the entire site to 755, but without success.
I don’t know how to fix this.
Please help me!!


(Mark Sealey) #6

Andrea,

It could be that the parent directory for the file has the wrong permissions.

Please send us the URL of your site; and a screen grab from Filezilla showing the relevant directory.

Do all your other images display?


(Andrea) #7

My site is www.ericclapton.it

I change the permiss of all the files, included all the subfolder 755.
I have this problem ONLY for the images on the webpage.


(Mark Sealey) #8

Thanks for the URL.

I see that it expects to find the image files in the /files/ directory:

src=​"files/​news-icon-18-1.png"

Are you sure that the files are in that directory, /files/?

Please post a screenshot of the /files/ directory from FileZilla showing the graphics files in it and their permissions. Thanks!

Images on your other pages seem to be in the correct subdirectories, e.g. http://www.ericclapton.it/styled-2/files/20170522_sgp_eric_clapton_rah-001.jpg

Is it possible that you have %Resources% incorrectly configured in RapidWeaver?

Which version are you using?

Then, did you make changes in RapidWeaver’s Publish Settings so that perhaps the docroot is not where your server expects - that is often ‘www’ or ‘public_html’ etc?

These pages may help:

http://kb-en.aruba.it/kb/a184/cartelle-presenti-nello-spazio-e-permessi.aspx?translation-detect=false
http://assistenza.aruba.it/kb/a154/come-configurare-il-client-ftp.aspx

Otherwise you might want to consider contacting your host - it seems as though there may be some special operations happening by IIS.

The links from this page are broken. But FTP settings might help.


(Andrea) #9

Thanks for your help, Mark.
The files are correctly located in the directory “files”. Only the home page files are in this directory, the others are in the various “styled” directories. Why?
This is a very strange problem… I use the latest version, the 7. The publish settings are right.


(Mark Sealey) #10

Andrea,

If you’re sure that the files are in the /files/ directory and that the permissions are correct, then - without seeing the settings you have in RW - it’s difficult to see what’s happening.

One thing you could try is to create a folder for your home page - such as ‘home’ and make sure all your images are there. Then republish.

I suggest contacting your host.

Is the docroot correct? Have you been using %Resources%?


(Andrea) #11

Please help me…I cannot fix this huge problem…


(Mark Sealey) #12

Andrea,

I’m sorry you’re still having this problem.

If you can answer my last question and contacting your host, that might help.

I suspect you have some sort of inconsistency in the way your RW project is set up - e.g. directory names etc. Impossible to say without seeing it. Good luck :slight_smile:


(Pete Schuder) #13

When I had any issues with a page, I would create a new one and add items one at a time and see if I could locate the problem. Just make the new page the default home page for the testing and add stacks one at a time. That would be my suggestion.


(Mark Sealey) #14

Andrea,

Yes! I completely agree with Pete’s suggestion. You could even start a new project and replicate the pages, one at a time, introducing elements one at a time until you see where it fails.

It’s hard to troubleshoot without your project file.

Elimination will take you a great distance. Good luck - and please say how you progress.


(Andrea) #15

Finally I’ve found a solution!
I delete the .htaccess file in the folder where the images are.