Not Found The requested URL /home/ was not found on this server. Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request


(Peter Corte) #1

I am having trouble publishing my site - the error message comes up as a 403 Error. I have finally worked out that the error is in a file that is linked to the Home Icon image in the top of the Menu Bar. As seen above, when I click on that Home Icon, it gives the Error message. Then when I Inspect this element I get this:

Trying to open the Website I get this:

Trolling the topics, I found that I need to change the name of the page to remove this error - so I need to know, which page and to what? Pressing the Home Icon link takes me to my website address http://ivf


(Mark Sealey) #2

Peter,

Have you changed the server settings in any way: you’re right of course that a 403 error often occurs when Apache, in particular, has been configured to disallow requests?

In RW what is the directory name for your home page?

Have you, perhaps created a directory, ‘home’, and put your home page files there?

Do you have access to an FTP client - like Transmit - which will allow you to inspect the directory structure on your server?


(Peter Corte) #3

Thank you Mark - I have a Webdisk of the Server - so I can inspect everything.

I haven’t changed anything that I am aware of on the Server

I have created a Home Page and copied my home page files into it - is that a definite no no?

So in the Server in the home -> IVFpharm -> I have a number of folders:

Thanks for your help so far - I just get the feeling that I’m on the edge of success :slight_smile:

Peter


(Mark Sealey) #4

Peter,

Thanks. One this is sure: Yes, you are on the very brink of success!

You should always put all your RW files into public_html or www (consult your host’s docs), not where you have them now.

public_html or www is the (web)server’s directory configured by default to correspond to the site’s docroot; the directories at the same level in the filing system hierarchy as public_html and www are not accessible by your web server… Apache or similar. That’s why you’re getting the error.

Strongly suggest letting RW itself use its inbuilt ftp routines, rather than manually ftp’ing them anywhere yourself.

No, don’t worry about directories on the server’s filing system, such as ‘home’ etc.

Build your site with the home page, e.g. index.html in the docroot… RW will rightly default to and suggest / for it once you mark it as your home page.

Then upload it all using RW’s own ‘Publish’ to public_html or www - and you should be OK.

Once you’re working, suggest manually deleting the files on your server in ‘home’ and any other directories you have created

This page should also help - good luck!


(Peter Corte) #5

Thanks Mark - I’ll try that - you’re very kind to give your time so selfishly - I am very appreciative. Peter


(Peter Corte) #6

Just to be clear Mark, the publish settings should be which one of the following?



(Mark Sealey) #7

Peter,

Yes!

If your host’s docs don’t make it clear exactly how to identify for RW the path to the directory you should use, you have nothing to lose by trying them each in turn - as long as you remember to tidy up (by deleting all the files in the area that doesn’t work) - so that it’s clean again when it does.

Does ‘Test Connection’ work in both cases: that’s really only proving that the authentication (login and password) are correct and that you can get to the server?

Then - whichever will allow you to get all your files from within RW, as you are working towards now - into public_html or, you should be OK.

This inquiry suggests your with Digital Pacific Pty. Yes?

If so, then this page suggests that it is indeed public_html that you want to be in :-).

You’re very close; this page might also help. Good luck!


(ben) #8

Hey @ufdogma,

The issue here is that your are publishing your site to the incorrect “path”. As @MarkSealey suggests, you need to use just /public_html as the path, as that is where your server is configured to display your website from. Change your publishing settings to use public_html as the path and then “Republish all files”. You’ll then see your site live on your domain name.

The reason you’re seeing a 403 error is because there are no files in the public_html folder (the folder used to display your website content), and your server is configured to disallow the listing of files within an empty directory (this is a good thing to have setup). So when a visitor currently visits your site, there is no index.html file in the public_html folder so the server returns a 403 error.

Hope that helps :slightly_smiling: