Images not Displaying


(Cynthia Taylor) #1

I seem to be having problems lately with simple things in RW. Now, on some of the pages I am working on, the images won’t display, including the site logo image. I’ve tried some different things that I thought might possibly help, but it’s still the same. I’ll try to put a link below for an example of one of the pages that has the problem. Any help would be appreciated!

http://educationoasis.com/new/main/printables/awards/classroom-helper-award/


(Mark Sealey) #2

Cynthia,

For the two cases which I can see on the page whose link you provide the error message is that you do not have permissions to access the image(s). That could mean that everything else is correct, but that the server can’t serve them because it doesn’t have rights to do so.

If you have access to a standalone FTP client, you could go both to the directories and individual images in question and make sure that they are set to 755. Or maybe set those permissions in the files’ Inspectors before uploading them.

Good luck!


(Cynthia Taylor) #3

Hello. I tried what you said. I used my Transmit FTP program, and tried to change the permissions to 755. Unfortunately, when I check them on my iMac computer, which is the one I’m using to work on the website, the images show in Preview and all of my browsers. However, when I check them on any other computer, the images aren’t displaying for me. Do you know what might cause that, or what else I may be doing wrong? Thank you for your help!


(Peter Danckwerts) #4

Actually, you have a number of Google Ads frames with https URLs trying to access http URLs. This won’t work.


(Cynthia Taylor) #5

OK, I will try to look into that. Thank you!


(Mark Sealey) #6

Cynthia,

What you describe may be a second issue. The paths may be wrong. I notice that at least two of the images on the page you link are in different places. One is in RWCommon; that ought to be displayed because it’s inside RW.

Were you able to set them to 755 using Transmit - exactly the right thing to do?

Was it the published images - published as part of the RW Publish process - which you ftp’d in to change?


(Cynthia Taylor) #7

Hello,

Yes, I did set them to 755 using Transmit, and the images were published using the RW Publish process. Actually, I may have found the problem, but I’m not totally sure, and I don’t even understand it. However, I believe the images are displaying now. I’m not sure if they are for everybody, but they are for me, even when I use a different computer. What I found was, I think the images were hotlink protected at my server, which I disabled. If that was the problem, and if they are showing OK now, I don’t understand why that would prevent them from displaying, but I’m just glad they are (if they are). Thank you so much for checking on this, and getting back to me, I appreciate that!


(scott williams) #8

Pictures are ther on my iPad. I do see some strange characters in the footer and a @import(( )) for the footer still though.
Scott


(Mark Sealey) #9

Good of you, Cynthia. Yes.

I also see what @swilliam sees.


(Cynthia Taylor) #10

I’m glad the pictures are there, and thank you for checking! And yes, I’m still getting those funky characters in the breadcrumbs in the bottom right of the page, and I’m still not sure why. Hopefully, I fixed the @import(( )) problem in the footer. I don’t know why that was still showing, but I tried to re-publish the page after inserting the new footer again. Originally, I had a footer made with Pluskit, but I replaced it with the Stacks 3 Partials. These pages are still under construction, but I’m trying to iron-out the problems I am having before I put the site live in its correct location. Thank you again for your help!


(Cynthia Taylor) #11

Thank you! Please see my above reply to swilliam, as that is about the same response I want to say to you as well. Thank You for all your help and support! I feel as though you may be cheering me on, and it makes me feel a little better about working with these problems I am having that I’m not sure how to fix. Thank You!!


(scott williams) #12

Cynthia,
Usually the weird characters are caused when you cut and paste something without clearing the formatting. Sometimes you can just highlight the text and clear the formatting under the format/harmless menu. I have seen times where I had to actually delete text and re-do it or put it in text edit, change it to plain text and re-paste to fix it.

Good Luck, you are definitely getting there :smile:


(Cynthia Taylor) #13

Thanks for sharing that with me! I have heard that before, as I was having trouble with the Joe Workman Letterpress stack. I had to do as you said to prevent it from producing the weird characters. Unfortunately, the breadcrumbs are created automatically with my theme, so I don’t know how to clear any formatting in there in order to stop the funky characters. I am using the Copper theme from SeyDesign. I do appreciate the great tip, and all your support! Maybe someday I’ll get all this working the way I had hoped for. :blush:


(scott williams) #14

I don’t have that theme but they come from the menu names right?
If you haven’t already, maybe try deleting the name of one that is weird, retyping it and republish to see if it fixes it.

All I can think of at the moment


(Cynthia Taylor) #15

Honestly, I don’t know how the breadcrumbs are created. They may be from the menu names, or somehow from the path of the page your viewing, or something else, I’m sorry but I really don’t know. Anyway, I could try retyping a page name and then republishing as you said, and see if that helps. At least it’s worth a try - thanks!