Index.php will not change to html

Whatever I do to change the home page to index.html - it keeps reverting back to php. The “advanced” settings are set to html as well, but the prompt that shows when trying to change it (Change Filename) is useless, bc it does not work. It still goes back to php.

Is it a stacks page? If yes, you might have on there a stack requiring PHP.

I’m only using foundation6 Site styles and a header w progress bar. It would not seem that any of that requires PHP. However - perhaps the progress bar does. ha. would be nice to “know”… OK. Just deleted the progress bar… no change. What gives??

OK, so I deleted EVERYTHING and it looks like “site styles” is the one. php for styles? hmmmmm. interesting. No wonder I get “double” index files on the server. I was wondering where that came from. Well, at least that problem is solved. F6 requires php apparently. :wink: Who would have thought. Thanks for listening. :slight_smile:

I doubt that. @joeworkman will know.

It certainly does not make sense, but having deleted site styles “released” the problem. (I tried quitting and restarting etc as well without avail) I did notice that in other pages this problem did not occur. Something funky - for sure. Glad there was a way to solve it without re-starting the whole project!

I just ran a test.

Foundation 6 with just a “plain” site styles stack Doesn’t force PHP extensions.

Now Site style does offer a lot of “addons” that you can select that might cause a switch to PHP.
For example, I have “Pagesafe” another JW product, It’s selectable under “Features”. If I choose that it adds the “Pagesafe” product to the site styles. Since Pagesafe requires PHP it changes the extension.


As @teefers explained. Site Styles itself does not require PHP. But some things that you could add to it may.

Curiosity question, what effect would it have had on this particular project if it was php rather than html?

There were 2 index files in the root. I had resolved that before and could not understand why it occurred again… naturally I tried to change it in RW when I saw (for no reason) the php extension in the settings panel. To my surprise… the “change extension button” would not work, even though I proceeded to “ignore” the warning about the extension change. Clearly - something funky. haha. Normally one would think after the “warning” that the extension change would take place. In this case… not so much.

And BTW, no other stacks were in there except Site Styles and a standard Container with Text and Image… Something may have been in there a long time before, but if if true, I should have been able to override the setting as RW promises me to let me do. But it didn’t… No big deal… just unexpected.

I say it was gremlins…

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.