Joe Workman email stack issue

Yep. Only one instance here.

Then I’m totally stumped. You will need to chat to Joe. If it’s not the theme issue as @Ruyton suggested.

You could try removing the Email stack entirely and re-installing it via RW, but I can’t see it’d change anything.

Thanks. Yes I have an older version so I’ve downloaded the latest one.
Any ideas how I update my theme within RW please?

Thanks. Just looking at a theme update now. Struggling with how to actually do the update having downloaded the files. The release notes for the theme indicated there had been issues with the inliner. Hopeful…

Download the theme file, run RW without a project file loaded. Drag the theme file onto the RW icon in the dock at the bottom of the screen and accept the update - can’t remember exactly what the prompt is.

Did you turn this on in the inliner?

CleanShot 2021-11-08 at 09.01.58

Its off by default.

Thanks Joe.
Before we get to that - I seem to have managed to remove the email theme from my RW whilst trying to update it.

When I download the latest version of the theme from your site it doesn’t seem to be packaged as I remember. ( Here’s a screenshot of the unzipped files ).

Would you please be so kind as to help me through getting the theme (re)installed and I can then look at your suggested Inline options question?

Thanks. Seem to have run into a problem with the Email theme now disappearing from RW.
Joe has responded here and I am going to try and get it re-installed with his help I hope.

Rename it to be Email.rwtheme I bet you have multiple instances in your downloads folder.


Thanks Joe and that was correct.
I’ve now deleted the old instance, renamed the new and double clicked followed by accepting the installation dialogs within RW. I did this once and the theme version did not appear to update to 1.2.0 - as evidenced in the add-ons window shown here post-installationScreenshot 2021-11-08 at 21.45.13

I then deleted the theme, restarted RW and reinstalled the new theme as before followed by another RW restart.

Unfortunately the version has still not updated - still shows as in the screenshot.
My ‘Inlined Email’ is still not showing BTW & I confirmed that the inliner ‘Only generate…’ checkbox is ticked as you asked initially.

Hoping you could please give a little further help and thanks for your assistance thus far.

I believe the checkbox should be unchecked is what Joe is saying!

My understanding would be that the checkbox would do as it is doing in your instance. Try unchecking that box within the email inliner stack and running preview again :slight_smile:


Yep. That has done the trick.

Now - I wonder if it is worth pursuing the issue with the theme not updating…

Davy, maybe you missed my earlier post on how to install the theme? Don’t double click the Email.rwtheme file to install, instead drag it onto the RW icon in the dock as I said below:

Thanks. I’ve done as suggested: dragged the new theme file to the dock icon.

I see a warning dialogue as previously:

" At least one addon is older or the same version as the one already installed."

If I proceed with the installation I see a green tick on the dialog and a ‘Relaunch Rapidweaver’ button.

Clicking the button causes RW to shutdown but it does not relaunch.

When I relaunch manually and check the theme version within ‘Addons’ it remains the older version ( as shown in my screenshot in post above ).

I am guessing that it’s desirable to have the latest Email theme installed so I would be glad of any further assistance that could please be offered. Many thanks. D.

What version is installed? Are you sure that it’s an old version?

The download is v1.0.0

I’m assuming that’s the latest version? I think this is the version Davy has?

It’s showing as v 1.0.0. ( see my screenshot above ). ‘Ruyton’ - Gary in this thread appears to suggest that the current download on your site Joe is actually 1.0.0 ( even though the release notes imply it’s a later version ) - I had wondered if this is what was going on so it’s interesting that Gary mentions this.

Hope you can help a little further please and thanks. D.

Thanks. I had wondered if this is what was going on… hmm…

The release notes that you are looking was for the Email Stacks. The theme version is not kept in sync.

Ah OK. Thanks. So the current theme is 1.0.0?

If so we appear to have a successful resolution of all known current issues so my sincere thanks Mr W and to @Ruyton @ablx @TemplateRepo @LaPan for kind and patient help. All the best. D