Joe Workman's Screens Stack 'a mismatch' with his Foundation Theme


(Dianne) #1

I have new versions of Screens stack and Foundation theme loaded but the error message states it is a mismatch. Any suggestions?
dmarney7


(Joe Workman) #2

Not much of a secret. You need to have the most up to date version of the Stacks and theme. As of right now…

Foundation Stacks 1.4.5
Foundation Theme 1.4.4


(Peter Danckwerts) #3

It’s worth reminding people that the Waterfall plug-in will help them check that their themes are up-to-date.


(Frank Carlsen) #4

Joe, you say Foundation Theme 1.4.4. I have Foundation Theme 1.5.0. Is it why I still get mismatch message? If so, where can I get Foundation Theme 1.4.4.
Btw. I use RW 6.2.4, Stacks 2 (2.7.1), Foundation Stacks 1.4.5 and Foundation Theme 1.5.0. Any new version I have missed?


(Frank Carlsen) #5

Oh sorry! I just saw it on JW doc portal that Foundation Theme 1.5.0 only works with Staks 3. So how can I get back to 1.4.4? (Where can I download it?) - Sorry for the mistake.


(Dianne) #6

I have purchased Waterfall yesterday and downloaded it today and it has confirmed the Foundation version I purchased 2 days ago is up to date. I purchased the Foundation Bundle for $99.00, which included the 2 addon packs and the starter pack which should also be up to date. The Screens plug in I purchased the next day from Joe Workman so I would believe it is up to date.

After down loading the Waterfall, updating the Rapidweaver and loggin out and restarting I am still experiencing the same problem.


(Brian LaPan) #7

I just heard from Joe that even though the portal says Foundation 1.5.0 it is indeed the proper download.


(Frank Carlsen) #8

You mean to say it is the proper download even I have Stacks 2?
If it’s so, I need help to get rid of the mismatch message. I still have mismatch message and it looks weird :smiley:

Thanks


(Joe Workman) #9

The button on the Foundation site is labeled as 1.5.0. However, 1.4.4 is what will download. I made that button display the current version of the theme that the site itself is running. Sometimes automation is awesome, sometimes it bites you. :slight_smile:


(Dianne) #10

I am so feedup with Foundation and the stacks I want a refund. I have received no reliable answers that worked and in fact some of the responses such as ‘Sometimes automation is awesome and sometimes it bites you.’ doesn’t provide an answer especially when you are the developer. I only purchased the software this month and it is a waste of my time and money. I tried reloading Foundation and it still doesn’t work.

From the comments made by the people you bother to put comments on line there must be many who just don’t bother.


(Peter Danckwerts) #11

I had a few problems when I started using Foundation, mostly because it is so different from other themes. However, the support from Joe and his team is great. Once you’ve got the hang of it, it really delivers, especially with superb responsiveness and the ease with which you can produce single-page sites. There are a few minor niggles with regard to unwanted padding and font handling but Foundation is now my most used theme. I have 2 finished sites using it and several more in the pipeline.


(Joe Workman) #12

@dmarney7 I am very sorry that you are still having issues. I was trying to be light hearted and was taking sarcastic shots at myself. Sorry if that did not come through. The entire reason that some people are having issues right now is that I am working on Stacks 3 updates right now. I have released many of these updates to users that are beta testing Stacks 3. You will not see these updates until you are using Stacks 3. However, when I did this, the Stacks 3 versions now got downloaded when you purchased. That slipped my mind on what I did for a couple of days. I apologize for that.

Here is what I suggest that you do…

  1. Download Foundation v1.4.4 theme here
  2. Download Screens v1.0.4 again from your original invoice that was emailed to you.
  3. If you are using the Foundation Stacks, make sure that you have v1.4.5. You can download those from your original invoice as well.

If you are still having issues, shoot us an email and I would be happy to help you out further and possibly go a screenshare so that we can fix this up for you.


(Dianne) #13

Thank you Joe,
I now understand where you were coming from. I have followed your instructions and there has been some progress. However now I don’t have Site Styles in the Stacks only in the sites Global. I have been following Ryan Smith’s training and I understand that is necessary and I did have it originally and now it is gone.
I appreciate your help.

Regards

Dianne


(Dianne) #14

Joe followed what you said but the Site Styles in the Stacks don’t appear in the Elements. It only appears in the sites Global. Please please help me.

Regards

Dianne


(Peter Danckwerts) #15

Let me see if I can help. If you are creating a single-page site, you can use the Site Styles stack which should be in the Foundation – Layout section of the Stacks menu. It seems a bit hard to believe that this is missing but I suppose anything is possible. For multi-page sites, you should use the global template (which you seem to have found) in the Stack Templates menu. As the name suggests, the global template is there so that when you make changes to the site styles on one page it is duplicated on all other pages (you have to have a copy on each page).

Using the global template in a single-page site will work no differently from using the stack on its own, unless you are planning to create a series of discrete single pages on your site. As well as being somewhat eccentric, this might be unwise, especially as having 2 different site styles open at the same time has been known to cause problems.


(Dianne) #16

Thank you Peter,
You are right I would use the Site styles from Sites Global, but I was only noticing I had Sites styles originally in the stack elements and now it has disappeared. Yes I wouldn’t be doing separate site styles for each page, but I might want to change a page’s background for better viewing purposes. You appear to have the Sites Style in the Stack Elements. If you can help me with this that would be good. Yesterday, when I tried using the Site Styles Global it worked, but it displayed itself as a colour picker and not like Joe Workman displays it. I have now dragged and dropped the Site Styles Global onto the page and now the message 'You must add the site style stacks to the page for Foundation to work properly comes up. You can see how frustrated I am.
Regards

Dianne Marney


(Robert Ziebol 🖖🏼) #17

Use the order lookup page
http://joeworkman.cartloom.com/lookup
If you do not have your invoice order, use the retrieve order history option.

and redownload and reinstall the stacks, see if that corrects it.


(Dianne) #18

Thank you for that suggestion I have done that at least 3 times with no success.


(Robert Ziebol 🖖🏼) #19

Can you share a screenshot of your Foundation stacks?


(Robert Ziebol 🖖🏼) #20

Perhaps you have closed a section of the Foundation stacks, like in this image:


You will notice that the Foundation Layout section is closed. That could be the issue.

We really can’t help you out without more information or screenshots. As Joe mentioned above:

We are here to help!