jQuery is not a function fontawesome-webfont.woff


(potted wires) #1

Hello,

i am getting these warnings in Safari - Develop - Show View Source

jQuery is not a function (in debugger)

Also at the end of the url there is

/rw_common/plugins/rapidcart/fonts/fontawesome-webfont.woff

and

/rw_common/plugins/rapidcart/fonts/fontawesome-webfont.ttf

in resources

Has anyone had this, or know what I need to do please?


(potted wires) #2


(Jason Bostick) #3

The latter two errors seem to be that those font files are not on your server. I wonder if a ‘republish all files’ would fix that.

I’m not sure on the jQuery error though… Is there a particular part of your site not working properly that might help narrow down where it is coming from?


(potted wires) #4

yes, it certainly looks like that.

I’ve tried changing layouts, cleared cache, history, saving, marking all pages as changed, and republish all files - many times in the hope that something might happen!

This morning I noticed that my iPhone had the change to RCP cart that I had made turning the cart colour white, but viewing on my Mac it hadn’t changed colour. very strange.

Also I found that RCP cart wasn’t adding to cart, but I think after trying to change colours in RCP style kit, it started working, (sounds odd that colour affected cart, so maybe it wasn’t that, sorry not sure.) and also is working on my Mac, but still no colour change.

The iPhone however did not update the change to some text in a 2 column stack.
which is the main change that I was trying to do. I wanted to line up a text stack in a 2 column stack underneath a picture.

In the 2 column stack there is also the add to cart. I did add a paypal icon in the 2 column stack, but I’ve have taken that out, as I noticed changes were not being updated on the text in the column, but not sure if it was the PayPal icon that caused the updating issue, or changing the RCP colours/css. Probably the later, still working on a solution! I need to make a note of every new website building action I take in future!