Krystal and FTP issues


(Kevin Atkins) #1

Does anyone here have any experience of RW7 and Krystal hosting?

Our FTP connection has always been a dog with Krystal, and I now can’t upload successfully. I’ve tried a number of variations of ‘number of connections,’ and whilst a single upload used to work in RW6, I can now no longer complete any publishing in RW7, as I it stops about halfway through with ‘Unable to publish.’

It doesn’t matter whether I have 6 or 1 connections, or 100 or 10 files, it will NOT finish publishing. The page I’m trying to publish has 40 files, but it will only get as far as 25 or so, before stopping.

I know Krystal can be a bit of a pain, and their support doesn’t offer much over the baseline replies, so I’m not banking on a huge amount of help from them, so what about any of you guys? Any luck in finishing an upload to Krystal?


(Rob D) #2

Do you have to stick with a provider that does not deliver goods and is not very responsive support-wise? Nowadays, there are tons of good competitive hosts that are willing to make your experience the best that can be – and for cheap… Check out Gregory Barchard @ChiliDog Hosting, for example. He is one of the RW add-on developers and everybody is praising his services.

Same goes for RW’s publishing pains. For years, I’ve been using Transmit app for publishing my RW sites and I have never experienced any glitch.

That said, I tried to publish my new site with RW7 (just for the heck of it) and – surprise, surprise – it worked! I used 4 connections (fast) in Extended Passive Mode. Anything above 4 connections was giving me the result you’ve experienced…


(Kevin Atkins) #3

Well, yes, unfortunately. I’m not responsible for the purchasing in our company, although I can make recommendations, which I frequently do, so fire fighting often becomes the norm for me.

We’re limited in that we can only connect to Krystal using Extended Passive and SSL for all communication, which is fine, but means that I’m limited in what I can try from within RW

A single connection sometimes work, sometimes don’t, and at the moment, I’m completely unable to publish from within RW. I can use other apps, although not always with 100% success, but RW will not finish publishing to Krystal’s servers.

We have a site on a non-Krystal server, and that’s fine, so I know it’s a combo of the two.


(Doobox Software) #4

I have been with Krystal for ten years, without issue. It surprises me that you have not had good experience with their support. I always find the small team there very amenable. I always phone with any problems, and have had some quite lengthy conversations, where there have bent over backwards to find any issue.

Anyway, what you really want to do is get up and running publishing in RW7.
I am on their Athena server and I use the following which works with the full 6 connections without fail :


(Kevin Atkins) #5

Hi Dooboox

Pleased to hear you’ve had a positive experience. We’ve had a number of tech issues raised with them, and they’ve always been most polite and helpful. I can’t, however, say that they’ve been particularly forthcoming with information on the causes of issues we’ve experience, or particularly effective at solving them, unfortunately, and I mean that with no ill will – that’s just our experience since being migrated to Krystal.

We’re on an Ares server, and are not able to login via non-secure connections (standard FTP). Any repeated attempts to do this results in an IP block for us, and either a 20 minute wait for the IP to clear, or manual unblocking via Krystal’s client area (of reachable).

We can only use ‘Extended Passive’ and ‘SSL for all communications’ in RW or we can’t connect. At the moment, the speed (number of connections) is irrelevant, as we’re unable reach our server from within our own organisation (which points to yet more blocking), but we’ve never been able to use any more than a single connection, as this spawns multiple connections that sit idle and eventually lock us out again.

We’re experiencing major issues with our hosting at the moment: our website is appearing only intermittently, including the cPanel and all mail for our organisation. I know there were some major updates at Krystal yesterday, which coincided with our issues, so I’m erring on the side of a misconfig at Krystal’s end.

Of course, it may also be DDOS related, as I know Krystal were the subject of an attack a few days ago. We’ve been in communication with Krystal all morning, but we’ve not heard for almost an over hour, aside from assuring us there are no issues!


(Kevin Atkins) #6

Well, 7.03 is here, and no change to the problem. Krystal are their usual unforthcoming selves, and Rapidweaver still refuses to close spawned connections, so still stuck with a single upload pipe.


(LJ) #7

make sure your publishing is set to Extended Passive mode - an upgraded RW6 project may not have this by default.

File > Publishing Settings


(Kevin Atkins) #8

Yes: Extended Passive is selected.

I’ve tried almost every combo of settings – FTP method aside because we can only use FTPS to connect to our host – but no joy.

The issue is slightly different in RW7.03, in that previously the connections would start, then choke the server and timeout. Now, however, they simply get blocked straight from the off, and only a single connection will get through.