RW7 Publishing problems


(eric shemtov) #1

I cannot publish with Rapidweaver 7 at all. just don’t connect to my Godaddy FTP.
I input all the exact info as i did on V6 which connect in a second. word by word letter to letter
and it will not connect. tried almost all possible option with no successes. i use Transmit and any other FTP software with no problem. I installed and reinstalled.
Am I the only one? Please help.


(eric shemtov) #3

Yes you are right 100%. but its there and it should function. imaging photoshop will have few function that don’t work will they leave it there or fix it?


#5

My feeling on this is that they should hire a developer of FTP programs like Yummy to sort it out and make sure it works as an integral part of Rapidweaver. I have too many random problems uploading with Rapidweaver but as a matter of convenience that is what I would choose if it actually worked.

Logically they should either fix the FTP or dump it but the problems have been ongoing for far too long now. I never had issues like these when using Freeway and FTP is the one area for me where Rapidweaver obviously has problems through multiple versions. I also agree that most new users would want to have FTP built in so they should fix it.


#7

Couldn’t agree more.


(Terry Vosbein ) #8

I am one of the many users for whom FTP works perfectly every single time. I mange 6 websites, some quite large, with almost daily updates.

I hope that they never get rid of Publishing, as it works seamlessly for me, and apparently for a whole lot of users.

And they are improving it with each update, or so they say.

i hope you are working with RealMac folks to solve the publishing problem you are having. They are a most helpful lot.

Terry Vosbein


(Terry Vosbein ) #10

No, I don’t mean sending in logs or crash reports. I mean contacting RW support directly and telling them what is happening. They will probably ask for a copy of the file. And they will solve the problem. By not working with RW on the problem you lessen the chances of the problem getting fixed for you and any others who may be having the same issues. They have always been diligent when I have had a problem arise and have always solved it. Have you written an email directly to Ben or Dan? I would be real surprised if they left you hanging and didn’t come up with a solution.

Terry Vosbein


(Terry Vosbein ) #12

Oh, sorry, when you mentioned that you didn’t have time to report things, and you suggested RW remove publishing, and that FTP only works 70% of the time for you, I took that to mean you had similar problems. By that description, it seems you might :slight_smile:

But I was also addressing the original poster, ericshemtov, with a suggestion for resolution beyond posting in the forum.

And I wanted to stress that of all the apps I use, the support team at RW is one of the friendliest and easiest to work with. If someone is having a problem, let them know. It helps all of us weavers.

Terry Vosbein


(Greg Schneck) #14

Yes, I highly prefer to use EXPORT and my own FTP client (I compared many and found Yummy to be fastest and with many options) . I also schedule file transfers (blog updates) to correspond to a 4:30 am mass mailing using a commercial mail system. I have NEVER really depended on RW publish. I always export and publish via ftp. That way I also know exactly what files are being updated and while in FTP I can just go ahead and delete old unused files too. I have always wondered how RW publish users delete old files.


(Terry Vosbein ) #15

I use Cyberduck to keep my site clean of old files.
:slight_smile:


(Aaron Marquez) #16

Hi @ericshemtov, I’d like to look into this further for you.

Can you send us an email with a screenshot of your publishing settings [Settings > Publishing]? Make sure the password is set to “reveal” so we can run some tests on our end.


#17

I don’t send in log reports of FTP failures because the email attachment is over 500mb…


(Brian LaPan) #18

The size is large because you haven’t cleared it in awhile. Clear your logs, recreate the issue and send those. Then, once sent, clear again.


#19

I cleared all my logs about a week ago using Onyx. It does seem to be rather huge.


(Brian LaPan) #20

You can also do it via the Help menu bar item.


(Aaron Marquez) #21

I’m not necessarily looking for logs yet, just your FTP credentials so I can run some tests on my machine. :slight_smile:


(Matt Johnson) #22

How? I tried Cyberduck and it wouldn’t get rid of my old files – it just
made a weird directory page and put my website as some sort of subdomain. Right now my site is totally screwed:/, any advice would be helpful.

Thanks


(Terry Vosbein ) #23

Cyberduck doesn’t get rid of anything. It is a file browser that connects via FTP to your host. It sounds like you logged on correctly if you see the directory page. Once there, you highlight and delete to your heart’s content, just like the files were on your hard drive.

You might try deleting everything in Cyberduck and republishing all of your files from RW. Or if that won’t work, publish your site to your hard drive and drag and drop the files into Cyberduck.

Terry Vosbein


(Greg Schneck) #24

Here is what I do sometimes. I publish my complete site and then use FTP to look at the file timestamps on the server. This is a quick and easy way to see exactly what RW is doing as far a updates. It’s also a good way to find old files but you must be careful not to delete video, ebooks, etc. I don’t put these type things in RW as resources. I upload video and such to my server with FTP and then just link to the file in RW.

I also use RW Export and FTP uploads almost exclusively, as I don’t trust RW Publishing. By doing exports and ftp I can see EXACTLY what files I’m uploading to the server (site.)

(I’m currently having issue in RW7 where changed files DO NOT publish or export. Even if a small change is made on page and even it the "change dot’ is set manually, THE NEW PAGE FILE IS NOT PUBLISHED OR EXPORTED. I sometimes have to export ENTIRE SITE just to get the one changed page I want.

I also wish the team would bring back the option to turn off SMART PUBLISHING. Option is shown in the pdf RW manual but in 7.02 there IS NO option to turn of smart publishing.


(Matt Johnson) #25

Thanks for replying – I gotta say, there’s a lot of helpful folks on these boards. I wish I could publish from RW, but no such luck. It goes through the entire process and then at the last minute I get the following error message: Couldn’t upload to your FTPS server: login denied.

Which is quite strange because the connection test goes fine and the publishing wouldn’t even start if the login didn’t work:/

I’ll be talking to the web hosting people, but this is something of a pain;) Any other advice will be appreciated and thanks again.


(Matt Johnson) #26

Hi – Yeah, I’ve exported and trying to use Cyberduck, but everything is a mess. My page turns into some sort of text file listing what my pages are named, but that’s it. Very strange. But, I’m contacting the web hoster and RW as well as posting questions. And again I have to say, these boards are great, I love you guys.