Link non perfetti


(Mancini Gaspare) #1

Salve a tutti. Ho inserito in una pagina blog, un post. Ho evidenziato una parola ed ho collegato ad essa una pagina di Wikipedia, mettendo la spunta “Open in New Window”.
Purtroppo non funziona, perché mi apre sempre la pagina di Wiki abbandonando la mia.
Un aiuto?


(Pietro) #2

Buongiorno @gaspare, se tu selezioni “Open in New Window” (apri in una nuova finestra) si aprirà sempre il link indicato abbandonando la pagina di origine. Deselezionalo e prova…


(Mancini Gaspare) #3

Salve Pietro,
ho fatto in questo modo (e mi funziona in tante altre pagine…) ma solo su questa non va…
Nello specifico, questo è il link:
http://www.tapascio.net/blog/
e la parola linkata è Herbie


(Wanni Soave) #4

Ciao Gaspare. Io di solito utilizzo come te il comando di apertura su nuova finestra quando voglio linkare un sito esterno e mi funziona regolarmente. Sarebbe forse utile conoscere la versione del tuo Rapidweaver, quale tema utilizzi e quali plugin hai visto che sfrutti un blog.


(Mancini Gaspare) #5

Ciao Wanni,
eccomi a risponderti:
Version 7.3.3 (18627)
Duccio della Multithemes
Nessun plug-in, ma la semplice pagina Blog di Rapid. Non è in realtà un vero blog perché non ho aperto alle discussioni.
Non capisco come si può mettere uno screenshot, in questo post, altrimenti facevo vedere che la spunta e il relativo “external”, appaiono nella finestra dove si “setta” il link.


(Pietro) #6

Non mi è chiaro quale azione voglia ottenere una volta cliccato sul link


(Wanni Soave) #8

Quello che sta cercando di dire è che quando clicchi sul link della parola “Herbie” del suo post, la pagina collegata non si apre su un nuovo pannello del browser (quindi senza abbandonare il suo sito) ma invece abbandona il suo sito per entrare nella pagina linkata. In parole povere come se non spuntassi la casella “open in a new window”.


(Wanni Soave) #9

Per prima cosa, forse sarà una domanda stupida, ma hai il tema aggiornato? Perché vedo dal sito del produttore che l’ ultimo aggiornamento apporta un bug fix sul text link come vedi nello screenshot.

Se il tema è aggiornato, prova ad inserire nella schermata in cui linki l’ url della pagina (e spunti la casella dell’ “open in new window”) esterna la dicitura completa davanti a www ossia http(s)://. Può sembrare una stupidata ma ho provato a fare un sito demo utilizzando il blog di RW e linkando una parola senza l’ http davanti non mi apriva correttamente il collegamento esterno. Purtroppo però non riesco a fare delle prove perché io utilizzo Foundation e Stack e non ho il tuo tema.


(Mancini Gaspare) #10

Scusa il ritardo Pietro, Wanni ha correttamente risposto a quello che vorrei ottenere…
Wanni, Ho la versione aggiornata è il link completo. Anch’io mi ero accorto della necessità di avere il link scritto completo, quindi anche con https. Per il momento, brancolo nel buio, perché proprio non mi accorgo di dov’è l’errore. Scriverò a Multithemes…


(Pietro) #11

Alcuni tentativi (che potresti anche aver fatto…) da provare:

  1. Crea un nuovo progetto con lo stesso tema e con una pagina blog di prova e verifica se ti dà lo stesso “errore”;
  2. Nel progetto completo, invece, rimuovi il link (remove link, cliccando sul pulsante anello spezzato) e creane uno nuovo (add link) digitando nuovamente la parola da linkare.
    Che succede?

(Mancini Gaspare) #12

Il secondo esempio l’ho già fatto, tra qualche minuto provo il primo…


(Mancini Gaspare) #13

Fatto. Creando un nuovo progetto e usando Duccio come tema, stesso problema. Cambiando tema, Old Page sempre di Multithemes, lavora bene. Quindi evinco che, è un problema del tema…
Giusto?


(Wanni Soave) #14

Credo proprio di si Gaspare, sembra un bug del tuo tema. Come vedi in questa vecchia discussione, non è raro incappare in qualche stack con il bug del “open in a new window”. Prova a scrivere “open in a new window” nel campo ricerca del forum… Nel caso che ti ho riportato io parlano di collegamenti fatti da bottone ma nel tuo caso credo sia proprio il tema. Letterina alla Multithemes…:sweat_smile:


(Mancini Gaspare) #15

Fatta… Speriamo rispondano… La cosa particolare è che questa è una funzione che uso pessimo, ma in questo sito credo sia l’unica… Quando il diavolo ci si mette…


(Mancini Gaspare) #16

Accorto ora, spessissimo… e non pessimo.


(Mancini Gaspare) #17

Buongiorno. Per eventuale interesse, vi scrivo com’è finita.
Multithemes mi ha risposto, dicendomi che è un bug di Rapid… e la soluzione è:

HI Gaspare
this is a bug inRW. we provide a further option to force the right behavior of the new window
in + combo options

hope this helps Multithemes team

Effettivamente il tema ha quella possibilità e funziona.
Grazie a tutti per l’attenzione.
Gaspare