Links are not working in my RW6 project


(Peter Kroman) #1

Hi there,

I know I have issued this problem in another post, but it is a long post and the problem is placed in the bottom, so I fear that it is not seen :slight_smile:

The problem is that added links is not working at all in my RW6 / Stacks3 / Foundation project. I have tried to add links to a picture and to some text, and I have tried to link to local pages and to URLs. Neither of them is working. It is simply not accepting that there is a link.

In this page I have added a link to the small thumbnail picture at the top right side and to the short text beside the picture - and as you will see it is not working :smirk:

What am I doing wrong?


(Stuart) #2

I looked at this. The problem is with the z-index of the content which is wrapped in a link. Using “target” to place it there, right? Increase the z-index value of that content.

The container is #stacks_in_637_page4 so CSS :-

#stacks_in_637_page4 {
    z-index: 9999;
}

Would do it, but I would encourage you to fix it using the stack settings.


(Peter Kroman) #3

Thanks @kryten,

Yes I am using Target to place the text. And when I set the z value to 9999 for thees Target containers the link works. But I did not use Target to place the thumbnail pics, and the link is still not working there.


(Peter Kroman) #4

Anybody who can help me with why my picture won’t accept to become a link :slight_smile:


(Stuart) #5

Hi,

You have z-index issues on that page. You cannot have a layer containing images and text around which you have wrapped hyperlinks, then drop a new layer on top and for the links underneath to continue to function. The layout/layering is suboptimal and I would encourage you to review that.

However if all you want to do is lift that one image to the top so that its link becomes usable again then add this CSS to the page:

#stacks_in_649_page4 {
	z-index:9999 !important;
}

But it is not an ideal solution, I don’t think.


(Peter Kroman) #6

Thanks @kryten

I have made some slight changes to layout. What do you you think about that :slight_smile:


(Stuart) #7

:+1: Much better! Well done :grinning: