Image links within partials do not work

Hi guys,

I have a partial that I used on every page that contains a few images. Each image as a URL link. The problem is that when published, the links simply do not appear for each image.

Taking the images out of the partial and putting on each page results in the image links working fine.

Question is, why don’t image links work in partials?

Thanks and regards, Steve

Foundation 1 or 6?

What version of RapidWeaver and stacks?

What image stack are you using?

I am using RW Version 8.7 (20860) and Stacks Version 4.1.4

You can see the working image links here: https://rfyl.org.uk/index.htm and the non-working images (in a partial) here: https://www.rfyl.org.uk/leagueTables/

It is the two banner images for R&T and Beacon of Light that I am having problems with…

Thanks.

Heck, that’s a ‘busy’ site …

I can see that the non-working image is definitely not a link, but without knowing how you have set up the page I can’t really help. I’m a Foundation user, but I have no idea if you are using a framework or a theme so I’ll step back here and hope somebody else can help you.

Thanks Gary - I am using a Theme rather than Foundation, but thanks for reaching out anyway :grinning:

Okay,

On the URL you gave that isn’t working, I only see the one image at the top. I see an iFrame (embed) that looks like it’s works(not much on it).

So without seeing some screenshots of what you have set up it’s impossible to help you out.

Sample…working.

Thanks Joe - good to know it does work for some people. Maybe it is the complexity of my page that is causing the problem…?

Did you use images stack? inside of partial?

I now have this working! I had a single column inside the partial, then 2 site images inside the column, both with links. I removed the column and just had the 2 site images, with links, inside the partial and re-published. This seems to have fixed it for me.

Big thanks and respect to the guys who reached out to me. You guys rock!

Steve

If you still have a copy of the file with bad links, or can recreate the problem, I’d really appreciate a copy of the file. It would be perfect for helping me find and fix the bug. This sort of test-case file is perfect.

A test case file just needs to make the bug and only the bug stand out like a sore thumb. So if you can make a copy of the project and do something to make the page stand out (call it THE BUG PAGE or something) and make the one stack with the problem bright red.

Or better yet, just delete everything that isn’t the bug. It’s hard to get the wrong page when there’s only one page. LOL :wink:

I’ll use this test-case to help find the bug. Then when I think I’ve fixed it, I’ll run the test project again and if the problem is gone, I’ll know it’s fixed.

Anyway, if you can share the project using a Dropbox link (or whatever sharing service you like) then I’ll download it and add it to the Stacks bug tracker. If the project needs any 3rd party stacks (pretty much every project does) then you’ll need to share your RW environment. Here’s how:
https://yourhead.zendesk.com/hc/en-us/articles/360033849994-Sharing-Your-Project-and-Add-ons

If the bug is gone and you can’t make it happen again or you just don’t have time to help, completely I understand. But these sorts of test-case projects are invaluable to me, so I have to at least ask. :smiley:

If you do have time, please post a link here, on our Slack channel (preferred), or send an email to our support folks (there’s a link at the bottom of every page of our site).

Thanks,
Isaiah

Hi Isaiah,

Thank you for your email. I will try to help with this!

Here is a link to my DropBox Support folder: https://www.dropbox.com/sh/mxkewa156bf33oo/AACh2UB2nM4RxsxZbWm9exxNa?dl=0

I have stripped everything out of the project except for the Information page (which is the simplest example of a page using the problem partial that I could find).

So… this page displays the partial content with working links perfectly in RW, but when published to my web server, the links no longer worked.

I found that editing the partial and removing the column after moving the images (with their links) outside of the column, it appeared to fix the problem.
You can see the working page here: https://www.rfyl.org.uk/information/

Would be interested to hear what you find.

Thanks and regards,