Problem with Page links


(David) #1

Hi all, I’m trying to link an image to another web page within my site.

This is the link panel:

The link does not work after the site is published.

Any ideas what I’m missing here?

OS/X 10.11.x, Rapidweaver Version 6.3.7 (15153), Stacks 3.0.5, Production Stack 1.0.4


Need help PICTURE LINKING TO ANOTHER SITE
(Oscar Schmid) #2

That you cannot do with this linkbox.


(David) #3

Hi Oscar, can you please explain more. I don’t understand. And what should I do as an alternative?

Many thanks


(Rob Beattie) #4

@daviddelmonte It should work. Does it work in preview before you publish the site?


(David) #5

Yep, it does work in Preview mode


(Mathew Mitchell) #6

I have no idea why this is not working, but the more expedient way to get things done may be to get LinkBox stack (as Oscar suggested). It’s a great stack, it’s free, and it works flawlessly. Check it out here:
https://stacks4stacks.com/linkbox/

On the other hand, if you want to bang your head against a wall trying to overcome RW quirks then by all means proceed without LinkBox! :slight_smile:


(David) #7

Well, I republished the site and now it is working ok. I have grabbed LinkBox, so thanks to all for help and recommendations.


(Mathew Mitchell) #8

Glad things are working now. LinkBox is a joy to use. Works particularly well with various Grid stacks so you have a nice look set of links (internal or external) that are responsive.


(Oscar Schmid) #9

With the linkbox you can link to a picture.
With this code you can bring a picture in your page.

<img src="%resource(your_picture.jpg)%" height="auto" width="600"alt="your_alttag"</img>



(David) #10

Undertood. Thanks again Oscar. I’m going to try Linkbox. I know nothing about it, but a problem that I’m having with the current grid system is that, while it’s responsive (a requirement), it does not order grid elements in the way I need them.


(Mathew Mitchell) #11

LinkBox won’t help you with a grid system that does not order things the way you want. What Grid stack are you using?


(Oscar Schmid) #12

I don’t speak of the linkbox from stack4stack.
I mean the linkbox in RapidWeaver.