'Add Link" Creates URL With /(null)/(null)


(Michael Thibault) #1

I can’t figure out what I’m doing wrong here: I’m selecting some text, clicking the ‘Add Link’ and select URL from the popup (‘Page’ doesn’t work either) and paste in the URL for the link. I close, I save, I publish… and when I go online I keep getting the links going 404 and now point to http://www.xxxxxx.com/(null)/(null) instead of, for example, http://www.xxxxxx.com/blog

What am I doing wrong?


(Mark Sealey) #2

Michael,

A couple of things to try:

First, when you say:

(‘Page’ doesn’t work either)

could that indicate something else may be wrong? Is it not appearing in your version of RW?

The Page option is to select a page from within your site, internal to your project; a link referenced relative to your own site, internal.

If you view the source of the page, what do the links look like there?


(Michael Thibault) #3

When you click on the Add Link button at the bottom a popup gives you the option of URL, Page, and Resource. Originally I selected ‘Page’ but I got the 404 error. Then I tried ‘URL’ this morning and get the same result.

I don’t know if this is what you mean, but in the page source I see this:

href="(null)/(null)" rel=“self” title=“Crew” class=“button”>Our Awesome Crew


(Mark Sealey) #4

Yes, that’s what I mean; thanks.

So you’re seing:

href="(null)/(null)"

even though you’re putting:

**http://www.**yoursite.com/directory/blog

or similar, into the URL box?

And you’re seeing that inside RapidWeaver 6’s own View Source window?


(Michael Thibault) #5

Ah, no, I got that from the browser. Inside RapidWeaver 6 I see:

<a href="http://www.yoursite.com/blog/">Blog</a>

(Vitor Costa) #6

Hi Michael,

Can you give us a URL to take a look? Does your Theme have a file named javascript.js?


(Michael Thibault) #7

Is there any way to send it to you without posting it publicly?


(Mark Sealey) #8

Are there any ‘special’ characters in the URL?

Are you by any chance pasting the UR into that box in RW?

Not that I know of.


(Michael Thibault) #9

Yes, I copy the url from the Safari browser and paste it into the RapidWeaver entry box. There are no special characters.


(Mark Sealey) #10

Try typing it in character by character in case there are hidden characters in the URL (from Safari) that are causing this.

And you have set the Web Address in RW?


(Michael Thibault) #11

I just tried. The same thing happens.

I set the web address in the publish settings, if that’s what you mean.


(Mark Sealey) #12

I’m sorry, I can’t see why this should be happening. If you can’t include the real URL (for which I’m sure you have good reasons) suggest you contact RM support. Good luck!


(Vitor Costa) #13

Michael, send me a Message clicking on my profile name.


(William Davis) #14

Did you name the Page? Folder? File Path? Has the destination point been formatted to accept the link?


(Michael Thibault) #15

Yes, all pages have been named and with a file path.

I have no idea what ‘destination point been formatted to accept the link’ means.


(William Davis) #16

My other suggestion would be to clear the formatting (Highlight, then Clear Format), and then append the URL to the link one more time. You might also want to check the path to the blog on your end of the file server.

Without a visual reference, it is difficult to diagnose. :mask:


(Michael Thibault) #17

I just tried that. It didn’t work either. Previously I’s just clicked ‘Remove Link’ button and re-applied the URL or Page connection.


(Mark Sealey) #18

Another way to go - since there really does appear to be something non-standard going on here - would be to create a second (test) RW project; then add a single page, make sure you have the Publishing Settings perfect, put in a single link on that page (maybe to a second, equally simple page), make sure you can get that uploaded and working.

Then one by one introduce the additional attributes to the href which you have now, and try different paths and links until something that you do causes the substitution, be it by the host, within RW or during RW’s publish etc.

Tedious though this may be, to find out where and why the substitution is happening seems the key. It’s a one step as a time elimination process, unfortunately. Good luck!


(Karn Broad) #19

Are you possibly trying to check the link while previewing a single page locally in a browser?

Have you tried a full Export Site locally, and does it then work as expected?

With best regards,
Karn.


(Gabrielle Vickery) #20

I was getting the same error when I was adding a url link. Took me ages to figure out the problem. Problem one was that at some point I had deleted pages and re-added them so the links I had were then missing, so I had to go in and re-link them. Also at some point I’d already put those text boxes in a ‘link’ stack, which I forgot about, so my links were getting confused! Sorted it out now though :wink: