MAMP + RW is not working for me


(Steve) #1

Hi all,

Downloaded MAMP, exported my RW site to MAMP htdocs folder, homepage working fine but when I click on a page link in my ‘nav bar’ all I get is Finder window opening highlighting a folder labeled "page-x’ (where x = number of page).

Can’t work out what’s wrong. Help would be much appreciated.

Steve


(Doug Bennett) #2

Under advanced settings is your file links are set to Relative to Page?


(Brian LaPan) #3

Try turning off Tidy Website Links in that same preference pane, too.


(Steve) #4

Thanks for the advice, Doug, much appreciated. I will try your suggestion later. I’m new to RW, coded my website before (in 2000 & 2013) with HTML & CSS — PHP just addles my brain but it seems to be essential to get a contemporary looking site.

Thanks again
Steve


(Steve) #5

Thanks Brian. Much appreciated. Will see what effect your suggestion and Doug’s have later.

This forum is wonderful in the help, freely and generously, given to the inexperienced such as myself.

Many thanks
Steve


(Doug Bennett) #6

Rereading the post, thought of something else. How are you opening the homepage? If you’re just going to the htdocs directory and clicking on the file that will get what you described.
You need to enter the address into the browser Localhost:8888 asuming you used the default port 8888 in MAMP.


(Steve) #7

Thanks, Doug.

File links was already set to “Relative to page”, but I turned off “Tidy website links” as suggested by Brian LaPan and that got me a Safari page with just the code. Tried again just now using 8888 and it works fine.

Thanks so much for your help. The website I’m rebuilding is http://stevehowlett.com. I’m a magician with wood, but coding… just makes my brain steam.


(system) #8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.