Menu Links Set to Folder not HTML file


(Odellia Firebird) #1

Hi,

I’m not sure if it’s because I’m using Rapidweaver 7 demo version but the menu links aren’t set correctly.

[[That said, I’m using the demo version because I’m still a novice and I bought the 6, apparently right before 7 came out, which doesn’t work anymore. And I saw 8 is coming up, and I thought it would be a good way to wait for it…]]

So, I’m trying to practice creating sites. I have Stacks 3 and using Foundation theme and all of the bundle. I’m finally getting somewhere with my sites.

I tried publishing it on my drive to see what it looked like. But when I click on the various page options on the top menu, I get the directory instead of the actual page. I created a test site using only included themes to see if it was Rapidweaver or Foundation and got the same result. It doesn’t matter which theme I use, when exporting, the program doesn’t link to the page correctly.

When I hover above the menu link, I notice the link is set to the repertory and not the HTML file. Is this normal? How do I fix it? (Is this because I’m using the demo?)

Trying to show the issue here:
2150
10


(Dave Farrants) #2

Download MAMP (free) and install it - you can then view your site as it should look when published locally.


(Doug Bennett) #3

There’s an option called tidy links in the advanced settings. That will remove the index.html or index.php from being published. Web servers will default to these files if not included in the link.

So you need to view the site on a web server, by publishing the site to a host, run a local web server on your Mac like MAMP or MAMP Pro. You can uncheck the option in the settings, but you won’t be able use PHP without a server.


(Odellia Firebird) #4

Interesting!

I will check both your advice and let you know if it worked!

I will try both MAMP and try to upload it to the server under a test url.

Thank you!


(Odellia Firebird) #5

You guys were right! Thank you so much!

Everything is working once I uploaded it on the server.

I’m really enjoying rapidweaver! Can’t wait for the next version!


(system) #6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.