Localhost Page Links?


(Gregory Anderson) #1

I’m creating a site composed of 2 RW files - a main site (andersonux.com) and a demo sub-site to be part of my online portfolio (andersonux.com/intranet). The main site has no problems, but on the demo sub-site, page links are not working. They all say “localhost” in the browser window. I have tried re-assigning the links, changing the url in settings to: http://www.andersonux.com/intranet/, and turning off “Tidy Website Links”. I have no idea why my links don’t work or how to solve this problem.


(Aaron Marquez) #2

@AndersonUX Everything looks fine on my end. Can you try clearing your browsers cache and refreshing the site/page?


(Gregory Anderson) #3

Thanks for the quick reply! Depending on when you tried it out, it may be because I fixed it. I’ve been publishing attempted fixes all day :smile:

It turns out it wasn’t all the links - just the Simple Button (1LD) stacks that comprise the Quick Links. I didn’t know how to link to internal pages with a URL, so was enclosing them inside the JoeWorkman Link stack. I think it must have been some conflict between the two linkable, nested, stacks causing the problem. I tried a trick I saw online for linking directly (outside of RW’s Link browser, for want of a better term), which was /folder/page file name, and that worked.

I don’t know for certain that a link conflict between stacks was the cause, but as long as it’s working, I’m happy. Thanks for the independent verification!

Gregory