Master Style not showing Themes


(Keith Lucas) #1

I have had a number of problems since installing RW6.

The most prominent is currently the failure of the ‘Master Style’ tab to show any of the installed themes. It just renders the Home Page using the ‘Default (Simple Business)’ theme, with no Style options except ‘Theme Default’.

I have tried reinstalling RapidWeaver, deleting and reinstalling Blocks and WeaverPix. Nothing seems to fix it.

Can anyone point me in the direction of a solution?

Thanks!


RapidWeaver Version: 6.3.3 (15046)
Blocks Plug-in: 3.4.7
WeaverPix Plug-in: 3.4.8
Themes: CA Lino, HV Elite


(Nik Fletcher) #2

Master Styles only shows your currently-selected theme. If you click the main toolbar’s “Themes” button, are all your themes shown?


(Keith Lucas) #3

Thanks for your reply @nikf. Yes, all the themes appear when I click the themes button.
The correct theme does not appear, however, when I go to Configure / Master Styles. As I said in my previous note, the page is shown in the Default (Simple Business) theme, with no style option.


(Nik Fletcher) #4

If you go to the RapidWeaver Preferences -> General tab, and select a different default them, does this have any effect?

—Nik


(Keith Lucas) #5

Nope!
I’ve already tried that, the correct theme has already been selected in Preferences > General.


(Keith Lucas) #6

It’s still not working @nikf. I have tried everything, even deleted and reinstalled the theme I’m using.
It’s set correctly in preferences but does not appear in Master Style. Incidentally, the site-wide code also fails… (I have to change the default logo position page-by-page).
Any ideas?


(Nik Fletcher) #7

In that case, please could you drop us an email - support@realmacsoftware.com. I’m not sure what’s going on here.

If you could include a screenshot of RapidWeaver, in the Master Styles section, with the theme drawer open and your theme for the project selected, that’d be really helpful.

—Nik


(John Van Slyke) #8

I have had exactly the same problem. i cannot change the default master theme for a project. I have spent many hours looking for a work around. None exists. How could this bug possibly have been allowed to slip through. The feature worked well in RW 5.

Not only is this is enraging, and it has essentially stopped me dead in the water.

I also note that the thread about this very serious problem has been open for a number of days. Very bad form.


(Nik Fletcher) #9

Please read my previous post - we’ll be able to help you work through this directly.

Thanks,

—Nik


(cezi) #10

hi,
i have a similar problem with the theme Reason, whatever you change in the theme settings, RW ignores it and brings up its own banner image; drives me nuts; were you able to solve this problem/bug in any way?

edit: RW ignores changes in the theme on a page level, however if you change the settings in Master Style of Settings and checked that every page uses the default Master Style, then you will see the picture that you want in the header


(John Van Slyke) #11

Short answer is that there seems to be a disconnect between the so-called default master theme and what can be set in the prefs for a particular site. I was finally able to get these to sync by starting over and making certain that the names of the themes are the same in both the default master theme and the master theme for a project.

I have had one hell of a time finding and changing the graphics JPGs for the headers of various themes. Still have not found a way to do this. Theme Miner seems to look only for RW 5 themes. RW 6 themes do not show up as selectable files.

I also have a significant deadline and found it necessary to purchase 5 different themes in order to find one that would work for me.


(Keith Lucas) #12

I gave up trying and finally ignored it. I created my own ‘master’ style within the theme (HCV-Elite) and simply applied this to each page.
If I go to the ‘Master Style’ tab in Settings it shows some arbitrary theme default - which, thankfully, looks nothing like the actual site.
While it is extremely annoying, after having paid for the upgrade to RW6 - as well as upgrades to the requisite plug-ins, it doesn’t, ultimately, prevent me from uploading the site correctly.
Not sure if this helps… hopefully RM is paying attention and will fix it soon!


(Nik Fletcher) #13

If you’re experiencing issues with this, please drop us an email (support@realmacsoftware.com) and we’ll be able to look into this.


(Mick Glossop) #14

Has this issue been fixed? I’ve emailed RW support, but it would be a good idea to tie off this forum thread for the benefit of any other RW6 users experiencing the same problem.


(Kevin Lock) #15

Go to the Master Style tab on the left. At the top of the page select the themes icon. Choose the new theme there, and this becomes the new master style.