Missing Links and Spinning Pinwheel

Hello Guys,

I am in trouble for quite a while. My RW project had been based on a Server of a company which doesn’t exist anymore. Before I left the sinking boat/company I copied the project and most of the related images to a hard disk. But I haven’t got all of the links/images.
Now everytime I open the project file, the Rapidweaver missing link window appears – but also another Finder window with the message that I do not have access to the server and should check the connection and so on. If I push the OK button it reappears directly and so on and so on. When I want to put the app Rapidweaver into the front the Spinning Pinnwheel appears and I can’t move or do anything, especially not reconnecting the missing links to the images (which I have saved on other places).

CleanShot 2021-01-12 at 12.32.31|690x403

Is there any possibility to get hands on my project again? How may I get to the window to relink the missing images?

Thanks for your help in advance!

Greetings from

SaM

Just checking that I understand this situation … you never had your RW project on a hard drive? No backups, no nothing? If that’s really the case then perhaps there is no fix. I’m not really sure as this is a very specialized situation.

If I’m wrong, and the project did exist on a proper hard drive at some point then there may be easier ways to help.

Hard drive or company server … the mantra is always back up, back up, back up. There are several ways to do this, but one option is provided by RW itself. Under “Publishing” you can back up to the hosting company (once a day, once a week, etc.). If you had that option turned on, and you still have access to the hosting company, then you could download the project file.

As for the images RW also offers some options. One is in the Advanced setting where it says Site Resources. One option is to “Copy into the document”, In most cases that is the best option. So if that option was selected then all the images should be contained within the RW project file. The images will have been renamed by RW but the content should be there. If this is the case let us know. There’s a way to dig inside and get those images (but be very careful).

Hi Mathew,

An existing backup is not the problem. I have several backups of the project and of the related images and other files. In every version of the backupped project files the missing image files »want« to connect to the original file on the former server position within a never ending circle.
As I mentioned, I do not have the connection to the former server any longer. Instead of this I have all the files at a different position on a different hard drive but the problem is, that I am not able to reconnect the files, because I can’t stop the searching process. I have only these windows which you can see in the screenshot attached to my original post.
I don’t have any access to the project file – also no access to any of the backup project files. When I open any of these files I will have the same circumstances.

I hope that my explanation is quite understandable …!?!

I’m betting that you tried this, but can you hit the Not Now button?

There’s probably nothing else I can think of. It’s a shame that you don’t have access to the original server anymore. Otherwise the “Copy into Document” option Mathew(@Mathew) mentioned before you saved the document probably would have worked.

Yes, I have tried it several times to push the button Not Now, but I am not able. When the Finder window for connecting to the server is not in front the Spinning Pinwheel (of Rapidweaver) is turning and gives me neither the chance to push the button »Not Now« nor »Resolve« nor »Close«.

It seems that there are hundreds of images which want to have access to the server and I hit the button »Ok« again and again … :grimacing:

I kind of figured you had tried it.
I don’t understand the language the messages that are being displayed.
If you think that the message is for each file, you could try and continue hitting ok until you eventually get to the end. That hit not now and save the project.

The only other option I could think of would be to add a volume to your Mac that has the same name as the network drive did.

Other than that, I’m afraid the only other option I can come up with would be to rebuild the project from scratch.

Thanks teefers! I have tried your first suggestion several times with hundreds of hits (although in the project aren’t as many images as that …).
Isn’t there another chance than rebuilding the whole thing from scratch? I have hoped so much, that you guys can show me the solution.

I’ve no idea if this would work for you but coming from my background in IT servers. When we have had similar problems where a volume share has been removed and some old workstation is trying to reference it and pausing for 20 plus minutes…

add the server name to your hosts file with an IP address of 127.0.0.1 (localhost).

If you are lucky RW will treat your workstation as the server and the link should fail on missing resource as the folder structure will be missing.

It’s a long shot but it might get you out of the hole.

1 Like

Other than what Nick @Pyrobrit suggested, I can’t think of anything else to try.

Okay, I will give the suggestion of Nick @Pyrobrit a try on the weekend and will let you know how the results are.