Missing Padlock on HTTPS Site, Source Code Errors

My newly renovated https website at frenchcaribbean.com is finally published and working well. There is, however, one small issue. While the security padlock icon shows up in the address bar in Firefox, it does not appear in Chrome or Safari. In fact, Chrome displays a circle with the letter I in it to indicate the site is not secure.

Fortunately, the website WhyNoPadlock.com provides a clue. Upon testing https://frenchcaribbean.com (or any of my site’s pages) five small errors are displayed. They are all the same:

“A form with the action of “http://frenchcaribbean.com//search/” exists in the source code of the tested page. This form needs to be updated to use “https://frenchcaribbean.com//search/” or another secure URL for your padlock to return.”

I can confirm these errors by searching the source code in a browser. Unfortunately, I’m don’t really know coding (one reason I love RapidWeaver). The website has about 180 pages so I’m looking for a simple solution to a potentially labor-intensive problem. The errors seem to be in the navigation area of the source code. Maybe it’s something in the Master Style area? Any ideas would be greatly appreciated!

You have a lot of internal links pointing to http: as opposed to https:. Do you have your website address set to https:// in General settings? Also, check in your publishing settings. It could be overwritten there. If you still have http: and not https:, change it and republish all files.

Can you show A screen shot where it is in the source (I’m on mobile at the moment and can’t look) wondering if it’s getting injected by your host.

Thank you. Thank you. Thank you - for your brilliant suggestions. The setting was still http: in the Publishing settings. I guess I thought that would change when the new SSL Certificate was installed.

Anyway, I updated the setting to https: and republished all files. Now there are padlocks in all the browsers!

Thanks once more,


1 Like

Thanks, Scott. The problem has been solved. I had inadvertently left the web address as http: in the Publishing settings. After updating the setting to https: and republishing all files, there are now security padlocks in all the browsers!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.