New RW8 files show as a folder instead of a file


(Francois Chaplais) #1

I am running Sierra 10.12.6 (16G1510) and rapidweaver 8.0.3. When I save a file (either from an older version of a file or one of the examples from the 5 new themes) the new file is shown as a folder instead of a bundle file. This makes RW8 unuasable for me.
P.S. I still have the latest RW 7 app installed


(Francois Chaplais) #2

I do not know if this is important, but my version of RW 8 is from Setapp


(Rob D) #3

This topic has been discussed in the past. See if this thread is of any help to you.


(Francois Chaplais) #4

I have done some housekeeping (uninstalling perian among others) but no joy. I would like to emphasize that RW7 does not have this problem, although it uses file bundles too. The only hack i have left is paragon NTFS for mac, but it is updated regularly.


(Francois Chaplais) #5

I have put all of my prefpanes away, restarted the mac, RW8 still saves folders instead of files bundle


(Francois Chaplais) #6

I cannot open the file from then finder, however RW8 opens it as a recent file. It also opens from the file “Open” item of the “file” menu. So it basically seems to be a finder issue.


(Francois Chaplais) #7

I have also tried the file saving on a dowloaded trial version, and the same thing (finder folders) exists, so I guess it is not a matter of setapp vs non setapp application.


(Brian LaPan) #8

Maybe make a copy and then try adding the .rw8 extension the name of the folder.


(David) #9

If you do a “get info” on the file, check and see if it says “open with RW8”. If not, select RW8 to open all files with the same extension (.rw8).


(Francois Chaplais) #10

It already has the extension :frowning: I have tried to set some kind of bundle bit using “forklift” and a “better finder attribute”, but it is not available in these apps. Open with in the finder is not since it is a folder. Set Info does not propose “open with” in the finder. I can do an “open with rapidweaver” within forklift, and it works.


(Francois Chaplais) #11

I have also replied to you in my reply to @LaPan


(Greg Schneck) #12

Thoughts: I saw this once and the folder icon was shown as the file was updating. But that was only for a second or two.

Are your project files on a cloud service somewhere? If so, copy them to your main internal disk and see what happens.

If you copy the projects to another Mac do they show as folders or RW projects?


(Francois Chaplais) #13

I have installed RW8 on another mac (which is under High Sierra, this one is under Sierra) and I do not encounter the same problem. Thanks for the idea (and thanks to setapp). So there is something with my system or an extension. Can somebody who runs sierra tell that everything is fine on his/her computer?


(Greg Schneck) #14

This sound like is not related to OS version nor RW. It sounds like perhaps a permissions problem or something with the OS. It’s as if the OS is not allowing an icon change/update once the save is complete.

Make sure you have a good backup and then run First Aid from the Disk Utility. See if it reports any errors.


(Greg Schneck) #15

And if First Aid on Disk Utility doesn’t help try resetting permissions:

Note that one of the things mentioned in the symptoms of the doc below is problems with sandwhich files.

Again, I suggest having a backup of your disk just in case anything goes wrong…


(Francois Chaplais) #16

https://support.apple.com/fr-fr/HT201560
says that permissions are automatically maintained by the OS starting from El Capitan.
Besides that, I have run Disk First Aid on my disk and it is OK. To make sure I retested RW8 and had the same folder problem.
I have also installed RW on my MBA which runs sierra and everything is fine.
I have also restarted my system in safe mode and the problem persisted.


(Aaron Marquez) #17

Hi Francois,

This is an odd issue that we rarely see, but I personally experienced this with RW7.

I followed the steps (downloaded the app) in this thread and added the .rw8 extension as associated with RapidWeaver 8.

There might be an easier/better way, but this did work.


RW8 Folder no Icon Issue AGAIN PLEASE HELP!
(Bernard O'Sullivan) #18

Read that thread and tried installing perian can’t even find it. I do not understand why I have this issue on a Mac laptop but not on my iMac desktop.

I have tried uninstalling all RW versions (well 7 and 8) and freshly downloading but nothing changed.

Fir God sake we went through hell with publishing issues moving from RW6 to 7 do we have to go through this again and pay for the privilege!?

It is deeply inconvenient and restricts where I can work on my sites.

PLEASE SOMEONE HELP!


(Francois Chaplais) #19

that good old prefpane did it. After scrolling the extensions to rw8, I linked it to RW8 (overriding any app settings), and boom, the .rw8 files opened in rapidweaver 8. Thanks a lot! @rapidbernardos58 might try this…


(Francois Chaplais) #20

try using http://www.macupdate.com/app/mac/14618/rcdefaultapp to set the attribution of the extension .rw8 to point to rapidweaver 8