RW Project Files saving as Folders - ElCapitan


(Stuart Tickner) #1

I might be missing something silly but since upgrading to ElCapitan all my .rw6 project files now appear as folders? They still open if i drop the folder onto the Rapidweaver icon in the dock but it worries me! They have the .rw6 extension buy they are now being seen as project files.

Can anyone help? Can’t seem to find anyone else that has this problem!


(Menno) #2

I don’t think RapidWeaver is at fault here. It appears to me the LaunchServices database is missing information about the .rw6 file extension. The file might have become corrupted. It usually can be fixed by rebuilding the database.
That can be done in several ways.
Maybe the easiest way is to use a utility application like Onyx or Maintenance (http://www.titanium.free.fr) or similar utility to fix that.
If it has an option to Rebuild LaunchServices then it’s suitable.
The image below shows the (Dutch localisation) window of Maintenance.

All file associations will return to the default settings.
If you once have set a specific application to open specific files, e.g. SomeTunePlayer to open mp3 files instead of iTunes, you may have to set those again.

Hope this helps,

Menno.


(Stuart Tickner) #3

Hi Menna

Thanks for the suggestion.

I tried that but still no change, tried restarting afterwards and that didn’t help either.

Do you know how the mac knows what an .rw6 file is, is it instructed when Rapidweaver is installed? in the old days you used to be able to manually assign extension to programs, but i doubt this can be done. Maybe if i re-installed Rapidweaver? It has only happened since i upgraded to El Capitan, so i’m sure its a more a mac problem than a RW problem.


(Menno) #4

Hi Stuart,

Has been two days since your reply, so maybe you’ve solved the problem.
Anyway, I have a few remarks and questions.

I have no idea how OSX (Finder) knows which application opens certain files. On installing an application that information must be exchanged somehow.

Yes, it’s still possible, but it’s not recommended to fiddle around with those settings. See part of a MacPilot7 window below. Read the warning.

When you ‘Get Info’ of the (should be) .rw6 file, what information do you see?
Does the extension exist or it is absent?

In the first picture below yo see a ‘Get Info’ window of some .rw6 file.
The second one shows the info after removing the .rw6 extension.
The icon changes to a Folder icon and I can’t open the file by dropping it on the RapidWeaver icon in the Dock like you can.

I don’t know if re-installing RapidWeaver could fix it. You then should probably remove every trace of RW’s existence before re-installing the software. Maybe a more knowledgeable person could give his opinion about that. e.g. @nikf

Sorry, I have no fix, had thought LaunchServices should fix it.

Menno.


(Stuart Tickner) #5

Hi Menno

Thanks for your suggestions.

The folder does have the .rw6 extension. When i get info it just sees it as a folder with no other details (see image). However when i drag it onto the dock icon it works. When i put it on my computer at home it shows up as a .rw6 project file and works as it should do, and that is also running El Capitan with the same version of RW

I tried re-installing RW which didn’t work, although i didn’t clear all traces off the computer.

This is very peculiar, doesn’t seem to have happened to anyone else!

Thanks for trying

Stuart


(Kurt) #6

Add me to the list of people with this problem. Tried rebuilding launch services database, but no luck yet.


(Stuart Tickner) #7

Kind of glad that it’s not just me with the problem, however there seems to be no solution. Tried emailing Realmac direct and they didn’t have a solution either.

Seems to be unsolvable! I’m sure it’s more of a ‘mac’ issue but it seems to have stumped everyone.


(Brad Halstead) #8

Just a shot in the dark here…

Try creating another user account on the mac (This basically resets things)
Install RW if not already
Create a new project, add a page, save the project to desktop

Does it show as a package icon or a folder icon?

If a Package icon then there is something wrong with your other user account.

HTH
Brad


(Menno) #9

@StuartT @kurtmacexpert It happened to me too the other day after I installed an application called File Spy (downloaded from the App Store). Just lucky to remember that.
Instead of thumbnails I only saw folder icons in my project window and the Finder did not know about the .rw6 too.
Of course I tried Rebuilding LaunchServices as that had worked before and I also had advised to do in this topic, but no dice. Darn!
Then I tried to narrow down the problem by using an old PrefPane called RCDefaultApp and found out that obviously File Spy does not know about RapidWeaver and his extensions and kind of ‘hijacked’ the .rw6 extension. RW still did open my projects, but the Finder saw them as folders.

The last update of the Preference Pane was in 2009, but it still works.
After choosing Extensions, this is what I saw:

After choosing RW all was fine :slight_smile:

Only the .rw6 extension was hijacked. The others all pointed to RapidWeaver.

There might be other Apps or PrefPanes to change the Extension ‘Owner’, but this worked for me and I hope for you and the others with the same problem too.

As @Turtle suggested you could create a new user account and that could fix it too, but if my solution works, it will save a lot of work.

Menno.

P.S. My version of RCDefaultApp is an unsupported Dutch localised version.


.rw-file are only displayed as a folder
(Stuart Tickner) #10

Thanks Menno, you’re a genius!

Downloaded and installed RCDefaultApp and found the extension, however just changing it didn’t work for me, even after a restart. However removing File Spy did fix the problem, not sure why i installed it anyway, but i didn’t at home so that explains the why it still worked at home.

Bye bye File Spy… happy Rapidweaver!