New site crashes all the time


(MJ) #1

I do not know what happened, but I have one Rapidweaver site which is not willing to work anymore in Rapidweaver. Upon opening (I can see the menu structure etc, but as soon as I move the cursor the system hangs (annoying coloured spinning ball) and that is it.

All my other rapidwaever sites do open normally. I tried to restore from a back up but also there it happens… is there still a way to save the info from that RW sandwich into another file. ? Just did a major overhaul from an old site to a new site (new theme etc… )

I did install Armadillo (worked flawlessly), did install RapidSearchPro (albeit the test version, so not yet paid, as I first wanted to see if it worked… it do not as of yet…so maybe could it be that stack?) and did install a cookie stack. Also had an issue there and uninstalled that stack.

Any idea ?


(Mark Sealey) #2

When you say you get the spinning beach ball, it suggests a resource which RW is unable to find. is that possible?

One way to determine this - tedious, I admit - is to list side by side all the resources (Stacks, Addons, Images etc) which a working site uses/needs, and next to that all those which this (hanging) site uses. Maybe somewhere in the second list will be the culprit. Good luck!

An alternative strategy is to start from scratch and add - one at a time - into a ‘test’ site each of the resources which you know the troublesome site uses until you discover a resource common to both.


(Lisa Sandler) #3

You can try duplicating the file. Sometimes that works… if the file is corrupt. If it’s a stack that is causing then that wouldn’t help.


(Christopher Watson) #4

I’d say send it to realmac. They can probably figure out what is causing the crash faster than anyone.


(Greg Schneck) #5

Do you backup your RapidWeaver folder? (the one that contains themes, plugins, stacks, etc?) If you know last time this project worked AND you have not added anything to themes, plugins, stacks, etc since then (that would have changed the folder) you can try going back to an old copy of it in TimeMachine (or whatever your backup is). It could be as mentioned above, that a resource used in that project only is corrupt. This is a good reason to make backups of the folder and be sure to make a backup before you add new resources to RW. This, in order to have have archived “version” of the Rw folder.