Spinning beach ball of death | 7.2x


(Butternut Squash) #1

Not ready for Prime Time, as another poster suggested? I have tragically to concur.

RW 7.2x hangs completely when attempting the most basic of functions:

  1. Double clicking on a stack to install it: BEACHBALL

  2. Porting a page over from a second file: BEACHBALL

  3. Clicking on Sitemap: BEACHBALL

Whereupon, I am obligated to Force Quit. When I reopen the program, each and every file that was open goes through the “transform” process even though they had all been originally saved. 7.0.4 was stable. 7.2x is a nightmare.

Am now obligated to return to that older version, after two days of work on the newer versions, the files of which can no longer be opened in 7.0.4.


(Dominick Designs Websites & Tech Training Seminars LLC) #2

this has been happening to me too. I have to force quit several times a day.

butternut squash? Yummy and sweet! Haha! Nice name.


(scott williams) #3

I bet it’s a plugin problem.
I would start by getting rid of all plug ins, then add back one at a time to see if/which one is causing the issues.


(Dominick Designs Websites & Tech Training Seminars LLC) #4

still spinning every day. at least 3 times so far today. Force quitting is my only option.

Plugins? I have (in addition to stacks) waterfall, meta mate, formloom, and code complete and easy tube gallery. I don’t see how these could affect my project since I’m not using any of these plugins except stacks.

Thanks for your support.


(Dominick Designs Websites & Tech Training Seminars LLC) #5

You are probably right. It seems to happen when I attempt to use the offsite page (which is a built-in plugin).


(Jason Bostick) #6

If it is the off-site page, it looks like others have had the same issue.

If you haven’t already, filing a report with Realmac might be useful.


(Rob D) #7

Hi, @devananda, EasyTube Gallery plugin from Cosculture was causing trouble in my project. I replaced it with YouTube Gallery stack from the same developer and everything went back to normal. Just FYI, in case you decide to use EasyTube Gallery in your project.


(Butternut Squash) #8

The problem for me does not reside with a plug-in. My file is completely Foundation based with the sole exception of Sitemap Plus.

Based on Scott’s @swilliam recommendation, I removed the Sitemap Plus page.

And what do you know? RW STILL HANGS.

So much wasted time…


(Robert Ziebol 🖖🏼) #9

What version of RapidWeaver?
What version of the Stacks Plugin?
What version of Foundation theme?
What version of Foundation stacks?

I would recommend opening the Addons Manager (command-7) and getting the numbers that way. Use the search box to find the answers. When searching for Foundation stacks, use the work Pack not Foundation. When search for the Foundation theme, use Foundation.


(Butternut Squash) #10

RW 7.2.1 and RW 7.2.2

Stacks Plugin 3.2.6

Foundation Theme 1.7.4

Foundation Stacks: Addons + Starter 1.7.13


(Robert Ziebol 🖖🏼) #11

OK, strange, not sure what to tell you. Good luck.


(Butternut Squash) #12

@zeebe @isaiah

To add a certain amount of clarity to an issue that is anything but. This is the sequence of events that transpired:

  1. Initially, I opened up a file in 7.2.2 that worked perfectly in 7.0.4. It went through the entire migration process.
  2. I experienced the problems I described in my initial post.
  3. I opened up the same already migrated file in 7.2.1. I experienced the same problems.
  4. I removed the Sitemap Plus page. Didn’t make a bit of difference.
  5. I re-opened the 7.0.4 file in 7.2.1, it went through the migration process anew, and, at that point,astonishingly presented no problems. That was yesterday.
  6. I re-opened that file today to continue working on it, and was presented with a Foundation Stacks update. I dutifully performed the update, whereupon the file again no longer worked, presenting with exactly the same original problems.
  7. I once again, from scratch, imported the 7.0.4 file into 7.2.1, and for the moment it is working.

What I suspect:

  1. There is some issue with the migration process, particularly into 7.2.2
  2. There is some issue relative to updating stacks with regards to a migrated file. I have no idea whether this would apply to a file originally created in 7.2x, but it is certainly happening to the file created in an earlier version.

I am obligated to continue to work on the file in 7.0.4, because, not being backwards compatible, I do not dare do otherwise. That is really a huge shame…it is a very large file, and literally takes forever to open and save. Speed improvement is the only good thing, in my estimation, about 7.2.


(Butternut Squash) #13

@zeebe @isaiah

OOPS. Spoke too soon. I subsequently had a few more thoughts:

  1. I saved the latest iteration of the file that had just been working in 7.2.1.
  2. I closed the file, and quit the program.
  3. I re-opened the program, and re-opened the file.
  4. It didn’t work anymore.

(Robert Ziebol 🖖🏼) #14

I have no clue, but since I can do all of that without your issue, it is definitely not a Foundation issue. Have you contacted Realmac support and sent them info and files?


(Dominick Designs Websites & Tech Training Seminars LLC) #15

I have been experiencing the same thing when to use off site pages. This is really a shame. And some of us are discouraged from reporting issues to Realmac b/c there is zero response. It takes time and effort to gather all the required materials for their report — but if we get zero response then we will be less inclined to continue providing reports. I guess the point is that even if we don’t hear back from them that doesn’t mean they are not receiving and reviewing the reports. But in a case like this, when the user has done their part, submitted all the requested materials etc…, then the burden lies on Realmac to address chronic issues like these.

At least we know it’s not foundation. Thanks for your support @zeebe

@Rovertek thanks for the FYI