Novice Rapidweaver user: can't upload site using FTP

Hi there,
Slowly climbing the wall here (Rapidweaver 8.2), trying to upload my website (it is very small contains 4 pages).
In the past I have used Dreamweaver and Filezilla as FTP client.

All seemed to be going well, when I do test I get " connection test successful", However I get the following when it starts uploading

Then I try and get the notice to see what failed to install and the Rapidweaver starts to hang and I have to force quit. (I am on MAC OS 10,15.7).

I got in touch with my hosting service and they thought it was really weird when they looked into my file that there was no index.php or index.html file.

I am completely lost now, I was so hoping for simpler days. Any help welcome

A screenshot of the publishing settings and the name of your hosting company would help.

here’s the screenshot, hope it helps


Since the test came back okay, my guess would be the path might be wrong.

I’d clear the path so nothing is in it (blank) and hit the browsebutton. That should give you a list of files and directories, select what directory the hosting company said to use.

I already tried that :slight_smile:

What happened when you tried that?

Why don’t you want to tell us the name of the hosting company?

I get the same notices and then nothing happens and I have to abort rapidweaver.
The name of the hosting company is on the screenshot. Its Netim.
I asked netim to refresh the hosting area for the website to make sure that there is nothing wrong at their end.

The hosting company has reset, and they say the following:

the hosting content for is reset.

Please note that our default index file should be replaced by yours when you upload your content to your public_www folder.

Where is this default.index file in Rapidweaver? In Dreamweaver I knew where it was, In Rapidweaver I am still in the dark?

RapidWeaver doesn’t work anything like DreamWeaver, it doesn’t “store” html or PHP files but generates them when you publish or preview them.

If you want the actual files you can publish them to a local folder and then copy those files in the folder with an ftp app.

If the path is empty and you hit browser button and you get the error message something is probably wrong with the settings. If you left stuff inside the path then it could be an invalid path. Sometimes with some ftp apps you start with a slash/ and sometimes you don’t.

If you can successfully publish with FileZilla then perhaps you can share a screenshot of the publishing settings you use with it.

does it have to be ftps? have your tried with just ftp?

Thanks for the info re Dreamweaver, I need to completely forget that and get my head in Rapidweaver mode.

In the meantime before I read your post I tried a couple of things and you can see the various messages I got
Screenshot 2021-02-09 at 17.05.26

Then I entered the details manually and got a successful test result.

then tried publishing and got the following Screenshot 2021-02-09 at 17.10.11

After the last attempt, when i look at the files, I have just noticed I have a new file, sitemap.xml

So there is a little progress, just not enough, will keep on trying.
I will take it step by step, I will try publishing to a local folder and see if that works.
Thanks for the help up to now, if you think of anything else let me know

Semi good news that worked, publishing to a local folder :slight_smile:

so what does that mean, there is something definitely wrong with the path

Are you able to connect with FileZilla?

  • if you can you can try taking the content from the local folder above (not the folder itself just the all the content including sub folders) and use FileZilla to publish to the public_www directory.

Do you have a screenshot of the FileZilla publishing settings?

I looked at the wiki from your hosting company and they don’t show anything using FTPS Like the screenshot shows. Looks like they show only regular FTP being used. FTPS can be tricky it requires two ports usually to work.


Another day, some more hope :slight_smile:
Fascinating, I tried both the FTP and the FTPS setting.
No validation and no connection with the FTP setting (I get the message: couldn’t sign in to your FTP server)
only with the FTPS setting do I get a connection it says: the credentials you entered appear to be valid.

I will try the path slash or no slash and then if that doesn’t work publishing by FileZilla from local.
Will keep you informed

Hi again,

I have tried the local folder and published via FileZilla. That worked! :heart_eyes:
As a workaround fine, but I quite liked the idea of one step publishing :disappointed:

Thanks so much for all your help!!!

Could you give us a screenshot of the publishing settings from FileZilla?

here it is

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.