Rapidweaver connecting to FTP but

When I run a test on publishing in Rapidweaver it passes and says it’s OK.

When I actually try to publish something it starts uploading, and then around half way through it stops and says;

FTP: unknown PASV reply.

rwftp

I have contacted the host and they said all my FTP settings are correct.

When I try to login with a different FTP program these same settings work fine.

What could be wrong with Rapidweaver?

Any other ideas?

The test pretty much just confirms that your username and password are ok.

Have a look further down the settings publishing settings box, there should be one called Mode, which should have a default setting of Extended Passive (default). Try the other options of Passive and Active, see if either of them work for you.

Host recommends that I use Passive, and it actually appears to be the only mode that passes the testing function.

While I’m trying to figure out what’s wrong with Rapidweaver’s FTP, is there directions on how to export the files so I can temporarily use a different FTP program?

Yes you can use the “Export Site” option. It will give you all the files needed to transfer via another FTP program.

Which host are you with?

When I click on Export Files it opens a folder dated from 2017.

No current files are in that folder. I clicked save so not sure why there isn’t a folder with the sites files in it…

Odd, the Export Site should just open a Finder window (usually default to the MacOS Sites folder within your personal home folder). From within that specify where to save to.

You can also setup in the Publish button on the far right and select from the drop down Publishing Setup and at the very bottom (almost hidden) Add New Destination… and there you can specify a local folder to always publish to, it then becomes one of the options on the Publish button.

I found the file but it appears to be a (.rw8.zip) zip file. If I upload that will the server still run it correctly?

No that’s just the RW file that has somehow gotten zipped in the process, it won’t work once uploaded.

Not sure what’s happening but try this:

  • File
  • Export
  • In the window that pops pick desktop and create a new folder there
  • The new folder should open once created
  • Export files to there
  • Come out of RW and find the new folder on the desktop

Within should be a bunch of files and folder, you should see one called index, a folder called rw_common etc. That’s your website. Take the contents of the folder, not the folder, and upload that to your web host.

Hopefully all should be well after that.

You can also change the publishing settings to publish to a local folder.

Where you select FTP there’s an option for local folder.

Just chose a new folder their. Then use an ftp app to upload everything from that folder to the host.

If you want help fixing the publishing problem, more information would probably help you get help.

  • A screenshot of the publishing settings
  • The name of the hosting company

The “couldn’t sign in to your ftp server” message is a very generic and sometimes misleading message. There’s an info button next to the message, that sometimes gives more information. There’s also a way to get the ftp log file if you need it.

1 Like

OK, it’s kind of working. The only thing that’s throwing me off is that in RW under Advanced > Default Extension I chose php because in one of Joes videos he said otherwise you’d have two index files on your server, and php would work better.

However in the folder on the desktop where all the files are I don’t see a php file, just a index.html file. Shouldn’t there be a index.php file in the folder on the desktop, or did I misunderstand what Joe was saying?

That would help. How would I get the log file?

The default extension only affects new pages/projects, it will not change existing pages. Was it changed to php after you created the site?
php is a good option, to change the extension of a page after it’s created you need to change it in the page inspector.

No, I changed it to php before I started to work on the site. I will try to update it. Thank you for all of your help with this!

Also. I went on the server and noticed that RW had started to upload some files. The odd thing is that RW placed those files in the root of the server, NOT in the public_html folder.

Could this be why the RW FTP is being stopped mid way? Could the server be detecting RW putting those files in the root and then disconnecting the server connection to ‘protect’ the website? Just my theory…

The host told me to leave the RW FTP server path blank, but I’m thinking that RW will need that to place the files in the public_html folder, correct?

1 Like

A screenshot of the publishing settings would help.

Have you tried clearing out the path and select the browse button? Then select the directory. Maybe a misplaced slash at the beginning or end of the path can cause issues. If you select the directory RapidWeaver will make sure the path has the correct path.

Are you able to publish with an ftp app like transmit or FileZilla?

At the bottom of this knowledge base article you’ll find instructions on producing the report. Unless you’re familiar with FTP it probably not going to make a lot of sense.

I’d suggest you follow all the steps in the article.

1 Like

Yep, transmit worked great when I did it manually to the public_html folder. I just need to figure out what folders/files to delete off the server that RW accidentally placed in the root. rw_common looks like one of them…

Thanks for posting the link for the FTP publishing issues :slight_smile:

Just compare what files are in the folder you exported to to those in the root of your server. You should be safe to delete any of those files.