Cannot upload via FTP server


(Sue Garrett) #1

Hi there - just made a few tweaks to website, went to publish and am getting the following error message…


Never had issues before and have checked with hosting - all good at their end - any ideas please?!
Many thanks
Sue


(Mark Sealey) #2

Please post a screenshot of your publishing settings (obscuring password, of course) + the name of the host and ideally the page on their site which details the settings they expect… they could have changed their requirements.


(Sue Garrett) #3

Hi Mark
Thanks for this - see below…

Sue


(Mark Sealey) #4

Thanks, Sue.

Until we know your host and the page which gives the details of what settings from you they expect (e.g. path as, literally ‘/htdocs’ and ‘ftp’ instead of ‘sftp’ etc), these things might be worth experimenting with:

  • do they definitely ask you to use a raw IP address (‘213.171.193.5’) as the server name?
  • your user name looks like a domain: has that worked before?
  • for some servers, Connections at 3 or 4 (instead of ‘6 -Lightning fast’) work better

Let us know how experimenting with these parameters goes, Sue. Good luck!


(Jannis from inStacks Software) #5

See the error message.

“Try to use another FTP mode” tells me “FTP” might not be supported any more and you might have to change to SFTP (Secure FTP).

Either switching the drop down already helps. Most probably you have to check with your hosting company.


(Doug Bennett) #6
  1. What happens when you press the Test button? That will tell you if the credentials are okay.

  2. If test says okay then clear out the path and press the Browse button (next to path). If that works That will actually “connect” to the host and give you a list of directories and files like finder. Choose the directory(folder) that the host company directed you to use.

  3. let us know what exactly fails with the above steps with screenshots and please provide us the hosting company name.


(Sue Garrett) #7

OK - here goes - have spent a frustrating morning on this and getting nowhere fast!


Full details of page from Fasthosts - all the settings are shown here - the following is my settings in Rapidweaver…
I really appreciate all the help as this is driving me nuts!
Sue


(Sue Garrett) #8

Hi there - I sent a help request to Fasthosts asking about this and they said nothing has changed and this shouldn’t make a difference… but thanks anyway!
Sue


(Sue Garrett) #9

Hello Doug

  1. Still get the error message that Rapidweaver cannot communicate with the server.
  2. Test fails - with this error message
  3. Fasthosts is the hosting company.

Thank you for your help!


(Doug Bennett) #10

If you’re failing on the test button then there’s probably something wrong with the basic credentials (server name, username or password).

You could perhaps verify and isolate the issue by trying a stand-alone ftp app like the free FileZilla. It produces a log file (right on top of the display.

I’d suggest you follow these detailed instructions provided by FastHost. That way if you need help from them getting it squared away you’ll be “following there instructions”.

Just publish your RapidWeaver site to a local folder first.

https://help.fasthosts.co.uk/app/answers/detail/a_id/143/kw/FTP


(Don H) #11

I think RW’s error message when username/password are incorrect says it can’t sign in. This error says it can’t communicate with the FTP server.

Do you have any anti-virus it anti-malware software that could be blocking the ftp traffic?

I would try a stand-alone FTP client and see it you can connect, as @teefers suggested.


(Sue Garrett) #12

Will try the stand alone - the weird thing is, I have 2 websites and both of them have the exact same error message which makes me think it’s definitely Fasthosts issue…
Will try the stand alone - have to take a break from it before I chuck my laptop out the window!
Thank you


(Sue Garrett) #13

Thanks Doug - will try FileZilla - many thanks for your input and help! I think it has to be a Fasthost issue as my other website is doing the same thing!
Sue


(Doug Bennett) #14

I would bet you are right. The problem you’ll have with dealing with most hosting companies help will come when you mention something RapidWeaver or any other ftp applications that aren’t covered by their “help” section.

That’s why I suggested using FileZilla as FastHost has a detailed step by step guide. So when you contact them you’re in their suggested app. Most of these help desk folks have cheat sheets and scripts for particular apps.

FileZilla is a great open source ftp application, it’s my go to ftp app for Linux. It’s easy to install and setup (should only take a few minutes). For most Mac users it appears to be intimidating as the ftp log file is right in front of you. Most other Mac ftp apps hide the log file.

Once you’ve figured out what exactly was causing the error then you can go back to RapidWeaver for publishing. Just apply any changes you made to credentials, paths, etc to the RW publishing setting.


(Dan M) #15

Can you visit your published page from your computer? I ask only because my internet provider has regularly blocked access to my published site from my IP address numerous times because the frequency of my RW publishing triggers some automatic protection on the server side thinking it’s a service attack. I have to manually release and renew my ip and all is good again. When this happens I can literally visit any domain other than the one that I publish to. Not likely but worth confirming.


(Sue Garrett) #16

Hi Dan - yes, I can visit both websites - just had a look and I’m using the same laptop as always…
I’m going to give FileZilla a go and see what happens…


(Indrid Cold) #17

Is FTP unlocked on the host? Many hosting plans require you to explicitly unlock FTP for an hour, a day, a week or however long.

If the RW test connect is failing then the problem
Is going to be pretty fundamental, like credentials or FTP is locked, something like that…


(Juerg) #18

When I check the site http://quaykineticsphysio.co.uk there is a “unsecure” browser message.

error .

These days websites MUST have https:// (instead of http://) otherwise nearly all internet browsers will at least give a warning message or refuse completely to load the page.

For the use of https:// (see the 's" at the end) you need a SSL certificate.
Check with your hosting company if they offer a free version of the SSL certificate.

Using SSL and https:// for the address may also resolve the connection issue.