Can't upload to FTP server

Hello, I am hoping someone may be able to help. I have this message when trying to publish, “Can’t upload to FTP server”. I spoke to my web hosting company - they say it all is fine their end and it may be to do with RW software. I am using version 7 at the moment.

Any suggestions and help much appreciated?

Thanks, Mia

have you tried to login with a ftp program.

I’m not sure what that is and where to login?

You should have a program like CyberDuck or Transmit to get to the files on your server…that is always a good thing to have and you will need it to clean up files. RapidWeaver doesn’t delete old files.
Look into it.
Yell if you need help.

Can you post a screenshot of your publishing settings?

Test: Click the test button, do you get an error? If so, post a screenshot of the error.

Browse: If the test is okay, then clear out the path field and click the browse button. It should connect to your server and allow you to browse for the correct folder to publish to. Select the correct folder. If you get an error when browsing, post it.

If both test and browse work, then try publishing again.

Thank you, this is the screenshot after trying the test:

Where did you get that Server address from, is this from your hosting provider?

There are only 3 things that could be wrong here, as FTP is a very simple protocol.

  • Server address
  • User Name
  • Password.

Have you tried clicking on the ‘Browse’ button, does that connect so you can see your hosting directory structure? If that path is wrong, it might block you from FTPing to that location, but the FTP details might actually be correct.

@mia I’m seeing several things that may be wrong. But the requirements from each hosting company are different so they could all be correct also! Here’s things that caught my attention:

  1. server. I put in the name of my website.
  2. username: this is a strange one. Not sure why the FTP@ is there.
    3 path: I use public_html/ (notice there’s not front slash)

I suppose each of these could be correct, but I doubt it. Probably at least 1 error in there. Who do you use for hosting? That may help some of us to help you better.

Thanks everyone. The settings are all exactly the same as I have used for several years without any problems, and I checked with the hosting the other day, and the settings are the same. I use 123-reg (UK).

I tried the browse option and got this message

Have you checked / read this? -

This also has some useful info -

You didn’t mention that these settings had worked in the past. The only thing you can’t see in the settings is the password itself as that is hidden. If you click the ‘Reveal’ box, is your password correct? If it is, then logic says that it’s something to do with your server rather than RW itself.

As suggested already, try with a simple FTP app, Filezilla is free and if that doesn’t work either you know it’s a server issue. If it does work, then it is RW.

One simple thing to try is changing the Mode from Passive to Extended Passive. Leave the other settings as they are.

If you’re going to try the browse button clear out what’s in the path first.

My first step would be to try the test button. If that works then you know your credentials are okay. If not then the server name, user name and or password are the issue.

Next clear the path that you have and press Browse. If that gives you a directory list like finder then chose the directory the hosting company gave you like public_html. It’s so much easier than trying to figure out if you need a forward slash to start or at the end or both. RapidWeaver will figure it out for you and fill the path correctly.

Here’s a post of mine from another similar/recent thread. There are occasions when this behavior can be a service provider issue, and even with correct credentials one can not access the server in question. Happens to me several times a year. Worth ruling out imo.

Thanks everyone for your continuing contributions. I have tried them all to no avail. I tried installing Filezilla and it was promptly ring fenced by Sophos antivirus software. The connection test shows my credentials are all valid, so unfortunately I am at a dead end now.

Mia, for clarity were you able to use Filezilla? You mention that a connection test shows your credentials being valid…was this a Rapidweaver test or Filezilla? Additionally I’m not familiar with Sophos as I don’t use any antivirus software, but have you ensured that it is not affecting your outgoing calls to the FTP server within Rapidweaver? By chance is the Sophos software a new addition to your system?

If you downloaded FileZilla from the FileZilla project site it won’t have any kind of virus or spyware. That would probably mean something is wrong with Sophos.

You said that the connection test works, next step clear out the path and press the browse button. What exactly happens? Do you have a screenshot of the message?

Instead of starting a new thread, I will post here to Mia’s thread as I have a similar issue I have been working for days to solve to no avail. I’m having a problem uploading some files. I have been successful in uploading some files so I am guessing it cannot be a general issue with publishing settings. But I keep getting this message:
“couldn’t upload to your FTP server.” I have tried to eliminate that it is a problem with the file, but I cannot figure if that is the case. I was able to upload the same files when I used to use IWeb. I have tried remaking the files (pdf files) but that doesn’t help. I have no way of determining what the problem is and when I ask for help I am just told to search all the publishing problems in this forum. I notice that there are a lot, a whole lot of other users who are having problems with RapidWeaver. I am starting to regret that I ever tried RapidWeaver. I have put so much time and effort into it that it would be insane to abandon it now. But that is where I am at–being driven totally insane by RapidWeaver. How does one get real help in solving this problem?

I should add that this problem only developed after upgrading to 8.3.

Thanks to everyone for your contributions, it has been most helpful to try these different options.

Finally a solution, the problem is solved! I got back to 123-reg about a separate issue which was that my website has a new SSL certificate, but it wasn’t showing on screen. The person at 123-reg did something to make the website or the certificate point at a different IP address (I don’t fully understand all of this tbh). She also gave me a slightly different IP address in the credentials to use. Finally I used the /public_html without the end slash permutation and anyway, something of that combination has worked and the site published.