Old contact page still visible, even after creating a new one and saving and publishing site


(Waylon Bryan Guillory) #1

Old contact page still visible, even after creating a new one and saving and publishing site. All setting are correct. Any help would be appreciated. I even deleted the old contact page; created a new one using a contact stack plugin; and it still had the old contact page visible in the safari or chrome browser. It the previews, the new contact is visible. In the browser, the old contact page is the only one showing. Weird…I know…


(Don H) #2

A link to the site would help.

Are you using Tidy Website links? That’s where each page is in a folder and named index.html. My guess is the new contact page uses server-side PHP code to work. If so, then it changed your page name to index.php. RW does not delete any files (only creates or overwrites). This means you have both an index.html and index.php files in the folder. Most web servers are configured to display the html version over the php version.

You’ll need to use an FTP app or your web hosts control panel to delete the index.html file for the contact page.


(Waylon Bryan Guillory) #3

I installed ymmy ftp light and connected it to my ftp server and no index.html exists. Now what?!


(Dave Farrants) #4

Who is your host? I’ve had similar problems lately with one.com

Have you cleared your browser cache?


(Don H) #5

A link to your website would help.

What was there? Only an index.php? A different file name? Did you see two files with the same name: one with html and one with php extension?


(Waylon Bryan Guillory) #6

I clicked “hidden files” again and the file was visible. I deleted it and will see if that resolves the issue. I did not see a .php file.


(Waylon Bryan Guillory) #7

This post was flagged by the community and is temporarily hidden.


(Doug Bennett) #8

First off drop the attitude, someone is trying to help you(you asked for help).

You said you didn’t see a PHP file, so you didn’t wait for an answer and deleted a file that you shouldn’t have.
We have no idea what “index.html” page you deleted, and you haven’t given a URL, you can always just republish all files Under the publishing drop-down button.
Your index.html or index.php file would never be “hidden”.


(Waylon Bryan Guillory) #9

The link to the site is: http://www.rememberingmarkeagle.com. He was my very close friend, for many years, and he died. It’s a tribute to him. Please help any way you can. Much appreciated.


(scott williams) #10

You do indeed have both a html form page and a php form page

http://www.rememberingmarkeagle.com/contact/index.html

http://www.rememberingmarkeagle.com/contact/index.php

You need to delete which ever one is “the old one”


(Don H) #11

It looks like @teefers helped you get the site back online. You probably deleted the main index.html file that was in the root directory. I wanted you to check for where you had both an index.html and an index.php in the same directory.

@swilliam confirmed that you do in fact have both an index.html file and an index.php file in the “contact” subfolder on your server. As he mentioned, you should delete the older of the two from the “contact” folder. It’s likely the .html version.

My advice was 100% correct. The issue is two index files (one html and one php) in the same directory. I had asked for the website address twice. I was going to confirm the issue and could have provided more specific instructions had you answered it either time. We all try to help as best we can. Sometimes that’s hard to do when we’re not provided enough information to help you.

Anyway, I think you’re on your way to resolving the issue.


(Waylon Bryan Guillory) #12

Sorry there was an error. Please try again message when trying to send an email using the contact page. Please help! index.html file was deleted in the “contact” folder successfully. Settings are correct, saved and published but still receive error message above. Thanks for your help. Sorry about being so harsh.


(Waylon Bryan Guillory) #13

Also, the old contact still appears instead of the new one. I deleted the old contact and replaced it with a contact stack plug-in yesterday. Not sure who can help me now…


(Brian LaPan) #14

Maybe try clearing your web browser caches. Or trying a different browser. I just went to your link, (the index.php) and submitted a test post (with test@gmail.com as an address) and the form seemed to work as expected.


(Waylon Bryan Guillory) #15

No. The old contact page that is native to RapidWeaver still exists and it doesn’t send email, which is why I bought the stack contact plug-in for RapidWeaver and using preview, it doesn’t work either.


(Waylon Bryan Guillory) #16

I either receive error message or, we cannot verify that you are trying to send an email from this form. Please try again, message when trying to send an email.


(Don H) #17

I’d double check that the new, stack-based, contact form page’s settings are Folder: contact and Filename: index.php and then I’d republish.

Make sure the “from” email setting is set to: something@rememberingmarkeagle.com, where ‘something’ is one of your email addresses on your domain. Perhaps info@.

Many hosts restrict you to only sending from an email address on their hosting server. That sounds like what the error is indicating.


(Brian LaPan) #18

When you say “stack contact plug-in” - which one are you referring to? Have you checked directly with the developer of that one? They may have some insight.


(Waylon Bryan Guillory) #19

I deleted the doobox contact stack plug-in for contact form; used the native contact form; set the email address for www.rememberingmarkeagle.com to be: wbryanguillory@rememberingmarkeagle.com which I setup on web.com and I still get this: We cannot verify that you are trying to send an email from this form. Please try again.


(Waylon Bryan Guillory) #20

Not sure about this part: contact form page’s settings are Folder: contact and Filename: index.php and then I’d republish. How do I check or change that. What location?