PageSafe not working correctly

Hi, I am testing PageSafe for use on my own artist’s website. It opens secure content sporadically. Which is odd. I can’t use this until I know it is working every time. Sometimes it just keeps showing the lock icon even after unlocking with the correct pin. I am confused!

I am not really technically savvy and only using this for my own web site as I like the flexibility of building from scratch. I am using RW8 and Foundry. I have contacted my web host and they confirm the page is being published with the pagesafe is there. I am using https and I can confirm PHP is running on the sites server and the version currently in use is 7.3.22.

The web site I am testing www.stephenbishop.co.uk and the page with pagesafe is www.stephenbishop.co.uk/1/ pin is currently 1234. There is only draft art content in there.

Any help would be greatly appreciated!!!

@StephenBishopArtist PageSafe is very reliable and good. It does not work on the link you provided for me. I believe a page with PageSafe needs to be PHP instead of HTML. Check if that’s the issue.

@joeworkman can help you out more than I can, but there’s a simple fix for the issue. I may be wrong about the PHP thing, but the stack does work quite well and reliably.

I totally get that the stack is great, it is just that i can’t get it to work reliably. I am sure I will love it when it is functioning on my web site.
Some times it loads and other times it doesn’t. I am guessing that people with more experience than me will guess an answer by my description of the issue?

Yes it is php and not html.

My web host confirmed this too.

Any other possibilities?

Big thank you
Stephen

@joeworkman

Yes, it’s PHP,
there is no index.html So that’s good.

Because it’s PHP, it’s difficult for anyone to debug remotely.

PHP is a server-side language, meaning the end-user(us) can’t always see what’s going on at the browser. It also doesn’t display errors to the browser by default but should log them to an error file on the server.

If you could post some screenshots of the PageSafe stack settings you used, it might help people trying to help you out.

You also could check with the hosting company and see where the log files are located.

Looks like you fixed it. It’s working for me.

Hi Joe, I think this is the issue I have not changed anything at all. Sometimes it works and other times not which I know sounds weird. I have the same issue on my imac, iphone and ipad. Problem is it needs to work every time for me to be able to use.

Will post some screen shots as requested. Hope this may help to clarify.

My settings. Thank you

second screen shot of the same settings lower down

Just tried it on my imac and it shows unlocking then straight back to enter pin on the lock screen. So not working for me at this moment…

I just tried it 6 or 7 time in a row and it’s worked. Maybe try disabling a browser extension?

Hmm, I just tried it twice using Chrome on a Mac, Catalina. Both times it appeared to unlock and then returned me to the locked state.

Rob

Hi Joe, I really appreciate you for trying this out. I can see it looks like I am crying over nothing when it works like it has for you. I have had it works for me and then it suddenly stops working for no apparent reason. I have tried it on my partners phone for example and it didn’t work, as well as my other devices and with different browsers and still get the issue of working every time.

Just to say that I am not changing any RW or SafePage settings or browser settings at this time.

Do you think it is a browser issue? What kind of extension would I look to disable? Clearly, I don’t want to have to ask my subscribers to disable extensions as it will be not be a user friendly experience.

Thanks again

Thanks Rob, this is exactly what I get. Then later on it works. I am stumped by this.

I’m getting the same thing as you.

There are some Javascript errors that “flash” on the console after you hit enter. They go away as the page reloads:

Uncaught TypeError: n.className.indexOf is not a function

Not sure if that helps @joeworkman?

Thank you for your expertise which is above my own. Looks like you may have identified something which I hope @joeworkman can further advise on ?

Just wondering if I should try getting a new download version of the PageSafe addon. Is it possible I have a corrupted version ?

Or is there a problem my end with my set up?

@joeworkman look forward to a response to see how I can resolve this. I really want to start using it and enjoying this stack.

I don’t know, but you can try. There’s an order lookup on this page, you can download another copy.

I doubt that’s the issue you are having, though. I don’t know even if the JavaScript errors are causing the problem.

Were you able to find any information from your hosting company about PHP log files?

I think that would be my next step in the debugging process.

Thanks for that, I will try a new copy when I get a moment.

I have asked my hosting about the php log files location and will get back.

Could someone walk me through how to replace the PageSafe addon to my RW8? Do I need to delete the PageSafe addon which is on there and then add the new downloaded one. Or will it replace the first copy with the second one automatically? Just want to avoid causing any more issues before I go ahead. Thanks again

It should replace the existing one. It will give you a warning message about a newer version (or something like that). Just install it anyway. Re-start Rapidweaver when it’s done.