PageSafe not displaying secure content after logging in - reverts back to the lock


(Marc Tison) #1

My Page Safe page appears: http://www.edenislandholiday.com/OwnerZone/
But when I login it accepts the password and then simply does not redirect to the protected page and stays on the Page Safe secure logon page.


(Gary Wann) #2

A bit difficult to see the problem without the PageSafe password :slight_smile:

I use PageSafe extensively and it works just as I need it to. Are you putting the PageSafe stack on the actual page you want protected? That’s how it works. It hides that page until the password is entered. Note that you should put a PageSafe stack on EVERY page you want protected. If all those PageSafe stacks have the same password, then the visitor will be able to see them all by just logging onto one of them.


(Robert Ziebol 🖖🏼) #3

What version of PHP do you have on your server? It needs to be 5.6 or higher, but I would see if you could get 7.1 as 5.6 and 7.0 are no longer supported by the PHP community.


(Marc Tison) #4

Hi Gary,

Go to: http://www.edenislandholiday.com/OwnerZone/

Temporary pin is: 1234


(Marc Tison) #5

My Host is running 5.6.


(Marc Tison) #6

I am.


(Gary Wann) #7

Questions:

  • Is you PageSafe stack on the page that you want to show when the password is entered correctly?
  • What Expire Time do you have set for PageSafe?
  • Do you have more than one PageSafe stack on the site and are the PageSafe ID’s different?

See the screenshot, this is a demo page. Note the PageSafe stack on the same page as the content to be displayed once the password is entered.


(Joe Workman) #8

Do you have https set inside of your website address in the project general settings?

I find that if I login, then manually go to https://www.edenislandholiday.com/OwnerZone/, it works!

This tells me there is some redirect rules or something going on with http vs https, not with PageSafe.


(Marc Tison) #9

I have the same setting.

I have only added StackSafe below that.


(Gary Wann) #10

Do you ONLY have a SafeStack on the page as well as PageSafe?

If so, as a test, remove the SafeStack and replace it with a text or paragraph stack with some dummy text. Publish the page again and see what happens. Can you log in and see the text/paragraph content?


(Gary Wann) #11

I can’t reproduce your error. I’ve set up a page with just PageSafe and Safe Stack and it works exactly as it should.


(Marc Tison) #12

Tx Joe!

Well that should have been obvious!
Nothing anywhere says it only works with HTTPS.
I updated the DNS settings via CPanel after registering the domain in CloudFlare.

Works now!!!


(Joe Workman) #13

It does not require https. However, you had some strange redirects happening somewhere. You should be using https anyways though. Glad that you figured it out.


(system) #14

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.