.plist issue unable to open file

Any Way around this problem??

Without knowing a bit more, it’s hard to say for sure what the cause is, Linda.

Have you tried these two things:

  • avoiding a full stop/period in the file name?
  • avoiding spaces in the file name?

Although the error you’re getting may seem to be directly related to the one .plist file, it might be a good idea to remove some other variables first.

Alternatively you could look and see whether there really is such a file by right/CTRL-clicking on your RW 8 project and navigating (carefully) inside it… ‘Show Package Contents’ etc.

If none of this helps, please supply a little more detail: is the Project yours, one you created - or did you receive it from someone? Did you move it in whole or part to the desktop? Why do you have a ‘Sites’ folder on your desktop? Were you previously able to save it?

Good luck!

1 Like

Have you tried shutting your computer off completely and then start up again?
It’s what I try first when I have a problem I can’t understand.
Do you have one of the memory cleaning apps running in the background that seem to cause problems for some? I might disable it also.

chuck b
Mac OS Mojave 10.14.5 (18F132)
RW8 Version 8.2.1 (20758)

I do not have any memory cleaning apps running. I have restarted the computer
It seems to only be one RW file that is having the issue. I have even gone to a backup with no luck.

Yes I have changed the name to just be Amy.rw8
Same issue, I had restored the sites folder to the desktop from a backup. I have moved it back to its home same issue.
I have looked into the show package contents and there is nothing there.
It is a project I created. Yes I was able to previously save it.


And have you tried removing the space from ‘Amy Caves’ in the Sites folder?

Shouldn’t matter - but it’s wise to eliminate every possible variable.

You can be pretty certain that if you looked into the package and there was really nothing (at all?) there, then the error is hardly surprising.

Somehow your file (actually a folder/package, as you realize) has become corrupt or otherwise unusable.

Taking you at your word (that you see absolutely nothing when Right/CTRL-clicking on the Amy.rw8 image and sliding down to the third item, Show package Contents), then there is no point at all, I’m afraid, in trying to use that version.

Did you originally build it in RW8 or an easier version?

(Please say if you’re confident about double-checking this from the command line (Terminal); otherwise we can guide you through that.)

You have no choice but to work from a backup or earlier version of the RW project… a clone and/or Time Machine.

And - importantly for the future - looking at the Project’s lifespan to see how that could have happened.

Good luck!

Nothing like Clean My Mac or similar?

Linda sounds as though she has experience with Time Machine and had thought through her plan
Linda can try restoring the entire hard drive to the last (or a bit earlier) known working state for that project, doing it overnight so it doesn’t interfere with other work.
But it will depend on how important that project is, and barring other potential problems.

With respect, Chuck, I’d be wary of that approach… the words sledgehammer and nut inevitably spring to mind because - as you say - that runs the very real risk of compromising all sorts other aspects of her working environment.

And of overwriting other (wanted) files and folders.

A good compromise, once it is 100% sure that the Project has ‘gone’ (and it’s equally important to find out why - not least so as to prevent it happening again) is to restore just that file from a point in Time Machine’s history when it was known to be complete and working.

Your advice has been spot on Mark.
I only suggest as a very last resort for a very important reason.
Yes, always find out why.
Linda, listen to Mark :wink:

1 Like

I actually have done a complete time machine restore. The file was saved in iCloud so it didn’t make a difference.

There was a post on Weaver’s Space today which described the seemingly same problem with files stored on iCloud - and a solution. Causality, not so much…



I did try taking out the space no change. I created it with an earlier version of RW. I do have one that I can go back to. I was hoping to not have to but oh well!
Thanks everyone for your suggestions. I had given it my best shot and thought that there might be something obvious that I was missing.


Could it be that working on it locally compromised the Project package’s integrity?

Then could it be a fault of some sort in opening it with version 8?

I’m sorry that you have to rebuild from an earlier version. Suggest saving often and checking and always uploading a copy of your .rw file to the server, as you can now do. Good luck!

It’s funny but I am really good about saving and saving as. This is the first time I have had issues.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.