Pluskit - @Import works in page body, not Sidebar SOLVED


(John S.) #1

Using Pluskit v4.1.1 in RW7.5.5 I’m having trouble with Pluskit’s @import function. It works fine for bringing simple (styled text) pages into the main body content of the page… but it has stopped working to import into the Sidebar. All I see is the @import((page_title)) codes.

Anyone else encounter this? And, better yet, have a solution?

I’ve got a support ticket in with Yourhead… just thought I’d pick the communal brain, too.

Thanks!


(John S.) #2

DOH! Please ignore the above… I found the problem. In migrating everything from @Stash to Pluskit, I was doing a clean up of the @Stash items as I went… not creating ones as Pluskit-importable pages if they were no longer in use.

Well… it turns out there were @Stash references to those items, even though they weren’t in use any more. So when I updated all the @stash(()) codes in the Sidebar to @import(()) ones, there was an item that was being referenced that didn’t exist. And, apparently, that blew up the whole @import process for the sidebar.

Removing the reference solved the problem and restored the rest of the @imports in the sidebar.

SORRY!


(system) #3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.