Preview (still) not working

I have not been able to Preview some of my pages for a couple of years now. See previous post here:

I’ve just upgraded to RW8.4.1 (20817) and it’s still not working for some of my pages. Pages at the “first” and “second” level can be previewed, but none of the pages at a “third level” will preview. Here’s a screenshot of what I mean:

I just have arrows on a subset, but the concept applies throughout. None of the lowest level pages can be Preview’d. If I publish, everything looks fine. It would just be nice to be able to look at a page before publishing it. I’d like to somehow file a RW bug with this so it get’s looked at someday.

Reading the old post and new, it’s got to be something “project” specific that’s causing the issue.

It looks like those are styled text pages. I just ran a test and got 6 levels down with a simple page and had no problem previewing.

Have you tried creating a new project (just for a test) and create a text page and nest it 3 levels deep?

If that works with just some text then I’d try copying some of the data of the pages that aren’t working.

1 Like

I’m using Stacks. No plain Styled Text pages.

That’s strange the icons in the sidebar don’t look to be stacks pages. Either Styled text or an Offsite page. Without the project file it’s going to be hard to say.


This option in the general preferences will do that…

1 Like

OK, just checked, and yes “Use Generic Page Icons” was turned on.

1 Like

Is it possible the theme doesn’t support a third level to the navigation menu?

What theme are you using?

It looks from the screenshot that you are on the page and select preview and then get the error?
I don’t think it’s a navigation issue as you still should be able to preview a page, even pages that aren’t in navigation can be previewed.
Do you get the same error when you right click on the page and preview with a browser?

Have you made a change to one of the pages that “couldn’t be found” and seen the change on the published page?


Yes, in both cases I get the same error.

Yes, that is how I have been working for the past couple of years. It’s just the preview that has not been working.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.