Problem with Armadillo and Disqus comments


(Pip) #1

I’ve added an Armadillo blog to my site and chosen to use Disqus comments.

I see the Disqus comments box below the post, but when comments are posted by people they’re not showing up there.

I think it could be to do with that Disqus is somehow seeing the filename as:

http://www.domain.com/blog/?post_id=34

but the link when you click on that post in the blog si:

http://www.domain.com/blog/?post_id=34&title=Welcome-to-my-blog

I’ve searched everywhere for how to sort it out so that Armadillo and Disqus are automatically referencing the same page, but can’t find everything. As it is Armadillo that is supposed to be doing the heavy listing I just figure it would automatically be using the correct name.

Any ideas as I need to get this fixed REALLY URGENTLY as the site has now gone live and there are lots of comments posted in Disqus that have been moderated and approved, but don’t show up as they’re set to appear on http://www.domain.com/blog/?post_id=34 and not http://www.domain.com/blog/?post_id=34&title=Welcome-to-my-blog


(Mathew Mitchell) #2

Your example links do NOT seem to go to an Armadillo blog. The commenting system definitely does not look like Disqus.

At any rate the comments seem to be showing up correctly to the linked location. To be very sure about things:

  1. you logged into Armadillo
  2. clicked on Settings tab
  3. chose Blog Settings (for the moment I’m assuming you have 1 blog only)
  4. under Blog Comments you clicked “Show Comments” and you provided a valid Disqus short name

If you did all those things, and of course if you’ve already set up a short name at Disqus, then all works great with Armadillo. There is no problem with comments showing on the permalinked page for each blog post.


(Pip) #3

They were just example urls Mathew. Here are the real ones:

http://www.paulsmithson.com/blog/?post_id=32&title=​welcome-to-my-new-site

and

http://www.paulsmithson.com/blog/?post_id=32

If you go to www.paulsmithson.com and click on the blog link you’ll go to the page listing the most recent posts and then if you click on the top one you’ll go to the first link I listed above and you’ll see there’s no comments.

But if you go to the second url listed above (i.e. without the ‘title=’ bit then you’ll see there are some comments.

I’m sure it must be something really simple, but it sure has me stumped.

Thanks for your help Mathew. Much appreciated.


(Mathew Mitchell) #4

I have no way to explain what went wrong here: very bizarre. But neither of the links you provide are supposed to be the permalinked version. The permalink should be:
http://www.paulsmithson.com/blog/?post_id=32&title=welcome-to-my-new-site

(BTW if you go to this real permalink the comments do show up fine.)

Your second blog post ($10 that paid major dividends) works just fine: the permalink is just as it should be. And comments show up. So this is not a general problem it seems, but limited to something weird going on with that first post.

I would suggest emailing Jonathan (the developer). (BTW I just sent him an email letting him know about this issue.)


(Jonathan Head) #5

@Pip As I understand it, Disqus keeps a record of the comments made on a certain URL. If there is more than one URL which can be used to display the same page (which is possible in Armadillo), comments won’t show up on one or the other URLs depending on which one the visitor was one when they posted.

I believe this is what you are running into - but that’s just a guess.

If I remember correctly, a prior version of Armadillo would only use the post_id in the URL when generating the RSS feed for blog posts, and likewise an early version of the Blog Headlines stack would do the same, but this is no longer the case, so this shouldn’t be an issue for you if you are using the latest version of Armadillo.

Apart from that, I don’t know of any reason why the URL to a post in Armadillo would be different.


(Pip) #6

I’m totally stumped. Seems really random to me. Been trying to figure out a fix all day but getting nowhere.


(Pip) #7

Phew. Fixed it but now got a new glitch.

Turns out there was a minor update to Armadillo (2.77) and as soon as I installed that and reposted the post, and reimported in the comments to Disqus, everything worked just fine. Argh! Wish I’d checked for that yesterday.

The only difference between the previous comments and the new one that didn’t work right was that the others were done in RW6 and the new one in RW7 so that could explain the mess-up. Don’t know, but it works now.

Unfortunately, the new version seems to have added a blank category in the blog left hand menu, which I can’t figure out how to get rid of. Another weird random thing. Hope that doesn’t take me a day to solve :slight_smile:

I’ve checked the obvious place (i.e. the Categories list in Settings), but alas, there’s no blank category listed so it doesn’t make sense.

Anyone know how to get rid of blank categories in Armadillo?


(Jonathan Head) #8

@Pip I’ve replied to your support ticket about this and will follow up with you there.