Problem with RapidWeaver 8.1 Final Candidate 4 (Build 20514b) and possibly sandbox


(Dan Smith) #1

I’m having a bit of trouble with what I think is the sandbox part of the most recent RapidWeaver 8.1 Final Candidate 4 (Build 20514b). I tried this beta version because it fixed several other problems I’ve had with the software. I’ve purchased a license for my use of the software and have no intention of ever purchasing the app from the Apple app store. I’m getting a wee bit tired of the popup, “This document uses files in multiple locations…” every time I open my projects.

I work on my projects on two separate macs, an iMac and a MacBook Pro 13 inch with a smallish internal SSD so I keep my Rapidweaver projects and exported files on a larger portable SSD while my themes/stacks are on iCloud.

This is probably what’s causing me my problems though this setup did work perfectly with the last distributed version of Rapidweaver . I’ve looked things over but I’m hoping there is a setting somewhere that I’ve missed that will allow me to turnoff sandboxing or hopefully sandboxing will only be part of the version that is sold on the app store. Even if there is someway to convince Rapidweaver that yes, you have my permission to rip and tear at will, please carry on bravely without bothering me further!

Because of my other problems I haven’t fully committed to version 8 of Rapidweaver so if this is something that will be a problem going forward I guess it’s back to version 7.


(Doug Bennett) #2

I haven’t seen that message, I don’t use a workflow like you do (sharing a drive on two different Macs). What do you need to do to get past the message?

Is it a permission issue?


(Paul Russam) #3

I’d put money on it being the same issue from 2016 last time AppStore compatibility was tried Resource Links Broken When Synced to Second Computer


(Dan Smith) #4

I can never get past the issue. The dialog box has two options Not Now and Choose. If I select Not Now some parts of the project will not display properly. If I select choose and select, as it suggest, my home directory it pops up and asks again. I usually click the root directory of the SSD and then iCloud finally selecting Not Now. Everything works as expected. If I save the file and then exit, reopen the same project I’m back to the same dialog box asking me to grant permission.


(Jannis from inStacks Software) #5

What about moving your projects to iCloud also?

Or: use GIT and a free service like Bitbucket (for Version control) to use as sync mechanism.


(Doug Bennett) #6

What parts don’t display properly? Are you using Resource folder?


(Dan Smith) #7

For the longest time I’ve been using the full url for images so that they’d show up both in preview and when published. This became a problem when switching over from http to https. With version 8 of Rapidweaver I thought I’d try using the the resource macro and found I was having a great deal of success. The odd time the resource folder would lose its mind and I’d have to reconnect some items but mostly it did a great job.

If I select not now from the “This document uses files in multiple locations…” dialog box the images are just question boxes when previewing. I don’t know what happens if I published because I’ve immediately exited Rapidweaver and then reopened, going through the process of selecting directories.


(JR Howell) #8

I too had that issue with the “This document uses files in multiple locations …”. This seemed to start with build 20502b. I went back to build 20385b and chose the Advanced setting “Pack into portable document” or something similar. Ever since doing that I no longer see the dialog box. In later builds I think they changed this setting to “Site Resources: Copy Into Document”.

I have no idea if this will work for you … just passing on my experience. I am now using 20514b and I don’t see any problems anymore.


(Dan Smith) #9

Found a project that didn’t ask me to update permissions, duplicated that and then replaced the content from my problem project one page at a time.

No longer get asked but to see the images in preview I have to keep the resources window open in the background. If I close that window I get the question marks. This is close enough to ideal. Went back to the old project and tried the “Site Resources: copy into document” but that didn’t help. Will see what the next update does before I do much else. Thanks for all the comments, suggestions.


(system) #10

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.