RapidWeaver 8 - Corrupted Project When Using Multiple Macs for Editing

Hi. I’m new to RapidWeaver and have started building a site but have encountered a problem with project corruption.

My setup:
(Me) iMac Pro (2017) macOS Catalina 10.15.2 Catalina 3GHz 10-Core Xeon W 128GB
(Wife) iMac Retna 5K 27" (2019) macOS 10.14.6 Mojave 3.6GHz i9 32GB
Drobo 5N2 NAS
RapidWeaver and Stacks are installed on both Macs and my family.rw8 file resides on the Drobo NAS. The RapidWeaver and Stacks versions are the same on both Macs.

Use case:
The plan is for both of us to be able to work on designing our sites but not at the same time. RapidWeaver would be closed on one Mac before opening it up on the other Mac.

What happened:
I’ve worked for several days to learn the basics and have had zero problems modifying, saving and publishing a test site. Today, I closed RapidWeaver on my Mac and had my wife open it on her Mac. She had zero problems modifying, saving and publishing using the same family.rw8 file that I had saved on the NAS using my Mac. After she closed RapidWeaver I opened the family.rw8 file on my Mac and received a popup message that a blog post had been corrupted. On further inspection I found that several of the changes she had made, saved and published were not showing on my Mac. When I looked at the directory on the NAS where the family.rw8 file is stored I found that I had both the family.rw8 file and multiple new directories that look like temporary files of some sort. (picture attached)

Am I doing something wrong by sharing *.rw8 files between multiple Macs as long as the file is only open on one Mac at a time? Is storing the file on a NAS a know problem? Is there a way to recover lost work from these extra directories? Any and all help is appreciated. Thanks.


It shouldn’t cause a problem sharing a file but it has!

I don’t suppose you enabled the backup frequency setting in the publishing setup window? If you did then you can download the last uploaded build of your site.

What happens when you remove the NAS from the equation?

I would also update both Macs to the same OS, in this case 10.15.2.

As far as I know, yes. It happens also e. g. when you store your file on Dropbox. The safest way here is to zip the file, upload it to the NAS. Then your wife can download the file, unzip it, work with it and zip it, then upload it again.


I didn’t notice the backup frequency setting (still learning) but I will turn that on. Right now I’m still experimenting so the loss isn’t too bad - just troubling. Do you know if all of those extra directories are normal or is everything supposed to be contained in the *.rw8 file?

The file is still corrupted after moving the file off of the NAS. Creating and editing a new project on the NAS seems to work fine now so it’s confusing. Why did it become corrupted the first time and what are the chances of it happening again after we put a lot of effort into the project. I’m curious if anyone else is having problems with projects stored on a NAS.

Upgrading the OS on my wife’s machine isn’t possible right now as she is running some software that isn’t currently supported by macOS Catalina. I do appreciate the idea though.

Good to know. That kind of makes sharing the site development a pain but at least it’s doable. I wonder if it’s a latency issue? I wonder what would happen if I stored the file locally on my Mac and my wife edited it remotely from her Mac. Not exactly the same as a NAS but a similar scenario. I may give that a try.

You could just copy the file to the Mac and then editing it. Then copy it back to the NAS and skip the zipping step. Then download it on the other Mac to continue editing… but always work on a copy which is stored locally on your Mac and not directly on the NAS…

Hi Jan.
That’s probably the easiest solution. Just to verify - everything is stored in the *.rw8 file? The other directories that showed up in my directory (see the screenshot) are not needed? Thanks.

As far as I know yes.

Have you tried using iCloud?

This may or may not apply to a NAS but may help in some way…

I used dropbox for many, many years on multiple Macs without issue - until recently…
• Actually using the project file in dropbox then after publishing, dropbox stoped being able to save the project file… It would just “hang” and try to save forever (again, after years of success)… Work around was to move the project file out of dropbox to local desktop, then after publishing, put it back in dropbox… This was about 2 months ago and I believe dropbox was the culprit… I have not gone back and tested it…

• Now I use iCloud to do the same thing without any issues at all… I am able to work on the project file (one Mac at a time) / Publish and save / open the project file on another Mac and resume work - No issues - Yet…

This has just started happening to me as well, exhibiting the self same symptoms. I suspect that something has changed within Dropbox, as my behaviours, hardware and OS remain the same.

Hi Chris,

I thought about trying iCloud but decided instead to edit the file locally on my Mac and create an alias in my wifes Mac so that she can get to it. That seems to work so far.

I believe that the problem with Dropbox and my NAS is that they aren’t native Mac volumes. Apple does some interesting things with hidden files and extended attributes that might be causing the problems but I’ve got no way of knowing for sure so I’m giving this method a shot.



I decided to edit the file locally on my Mac and create an alias in my wifes Mac so that she can get to it. That seems to work so far as long as we’re careful not to try to edit the file at the same time.

I believe that the problem with Dropbox and my NAS is that they aren’t native Mac volumes. Apple does some interesting things with hidden files and extended attributes that might be causing the problems but I’ve got no way of knowing for sure so I’m giving this method a shot. This method has the added benifit of being backed up by Time Machine so that’s a plus.

I have had the same problem with Dropbox. Without going into multiple reasons about what I think is going on, I have to turn off Dropbox while working on and saving a project, then turn Dropbox synching back on when done. I discovered one thing: if you save a Dropbox file while it is still syncing a previous save it gets very confused and that’s where corruption begins. It’s really a major issue.

Sounds like a good workaround for the dropbox issue. I guess that the key would be to make absolutely certain that the file has finished synchronizing before reopening the file.

Here is what I have observed. Almost every file that is synced with DropBox (and I mention this because it could be with NAS and other services) loads what appears to be one file when you look at the DropBox upload window. For example File.indd or File.docx uploads as ONE file. When RW8 files are synced with DropBox, watch the DropBox status window. Often HUNDREDS of files are listed as being uploaded separately. If you save an RW8 file, work on it a little then save it again before the previous save is complete, DropBox gets confused and that’s where the weird syncing issues start. Often it will FREEZE on one file and never upload. That’s why m suggestion is to TURN OFF Dropox syncing while working on RapidWeaver files, then be sure to resume syncing when the file is CLOSED. I’m not a programmer - so, is this now a Rapidweaver problem or a syncing problem. I don’t ever remember this occurring like this with previous versions of Rapidweaver.

RapidWeaver project files are physically a folder. It’s a special kind of file called a package. If you right-click on a any package file you’ll see an option to “Show Package Content”:2020-01-03_14-51-14

You can take a look and see they are complex folders, with lots of small files. (Don’t change anything this way.

Everyone seems to be having issues with dropbox lately. I stopped using a while back (removed it from my Mac), as the helper app seemed to have a memory leak.

I would suggest you look at other options like iCloud or OneDrive.

It was pointed out on another forum that there’s a specific issue with Dropbox at the moment which may or may not be related to yours: https://status.dropbox.com/

I haven’t had any issues until recently but am thinking of trying something else given that my renewal is a few weeks away.

Well, so much for the idea of editing from an alias on my wifes computer to mine to edit. We ran into the same file corruption issues that I did on my NAS and that others are seeing on Dropbox. We’ll just do as Jan suggessted and copy the *.rw8 file to the local computer that we want to use. We’ll edit, publish and then copy it back to a central location until we need to work on it again. Kind of a pain but worth it not to have to deal with file corruption. Sigh.