Problem with Resources and Previewing in RapidWeaver 7


(Michael M.) #1

There ist a problem with the HTML5 video stack when used in a RapidWeaver 7 project:

I create a Foundation test project in RapidWeaver 6 and embed a video via the HTML5 video stack. I can see the video in RapidWeaver preview as well as in local browser preview. That’s what I expected. I upload the project, everything works fine

I convert the project to RapidWeaver 7. Now I cannot see the video in RapidWeaver preview, same in local Safari preview (local web server). Preview in Chrome works fine, but FF has the same problem. I only see a black area. I have to publish the project to see the video in the published project.


(Mark Spaulding) #2

Yep, that is what I found too. Works fine on he live server so I was OK with it.

Blessings,
—Mark


(Robert Ziebol 🖖🏼) #3

are you using Resources??


(Michael M.) #4

Yes, I do. It’s the option the HTML5 stack offers


(Robert Ziebol 🖖🏼) #5

OK, but are you using the RapidWeaver 7 resources area? If so, that is the issue. It is a known bug, but I have not seen anyone at Realmac acknowledge it publicly yet. Have to wait for a fix from them. This is NOT an issue with the HTML5 Video stack. Try it with a hosted video file on a server, works great in Preview.


(Ben) #6

I have exactly the same bug with other stacks as “play” and “impact”. Does anyone has a solution?


(Robert Ziebol 🖖🏼) #7

use actual links. You can actually use resources, but you just have to publish your site. When you do, the resource will have a URL.

Here is what it looks like before you publish

And here is what it looks like after you publish

You then click on the button that says Copy URL and the open the stack you want to add the resource to and paste that URL where it goes. Like this in the HTML5 Video stack and then you can preview in RapidWeaver.

It is not a perfect solution, but it works.


(Mark Spaulding) #8

The latest RW7 beta fixes this bugs in preview.

Blessings,
—Mark


(Zeb Ernest) #9

Interesting thread and right on time. I have published my site. Captivear.com/nthd. At the bottom of the home page. I have the video in 7.1.7 resources copy URL remains just the website name with a blue dot like it wasn’t published. I’ll mess with it some more following these guidelines ROBERT mentioned.

If that fails I will just call it from the server. I’ve already seen the movie. Now I want everyone else to see it.
Is there a recent beta of 7.1.7x somewhere?

Thank you


(Zeb Ernest) #10

So I tried the suggestion. no dice. Suspect is that my resources upload to the server but the blue dot next to them remains. using 7.1.7 on sierra 10.1.1

Still the server files are there including resources. So I just typed in the full path to pull it out. that didn’t work. So in my ftp client I grabbed the url and typed it in my browser. worked. Co
py into link. Worked. Problem solved!!

ha!

What’s up with resources not updating in 7.17?

You can see this as before at http://www.captivear.com/nthd/index.php