Problem with upgrade from 5.4.1 to 6.3.5


(George Peacock) #1

I summoned the courage to do the upgrade a couple of days ago. Saved all my current files with 5.4.1 then upgraded. I am finding however that whilst I can use 6.3.5 and I can mostly publish without issues (has aborted several times) when saved the files appear to have some kind of corruption. When I try and save them back on the server I get the dreaded -36 error in finder.

IO have tried dot_clean but does not fix. Only happens with files I have saved in RW 6 post upgrade. Any advice?

george


(Nik Fletcher) #2

Could we get a little more detail here? Are you trying to save directly to the server from RapidWeaver?

—Nik


(George Peacock) #3

No I am saving the files locally on Desktop. But when I try and move the files to our server - thats when I get the error -36.

Never had it before and it only happens when I open projects on RW 5.4.1 and they get saved in RW6 on the desktop. The RW 5.4.1 versions are all fine and can be moved round no problem. It seems like RW6 corrupts part of the file, that said I can open the files saved on the desktop ok in RW6 and I have been able to edit them (though clearly not done much of that give this issue). However it does mean that currently RW6 is unusable as clearly we cant leave files stored on a local machine - they need to get backup up on our server like everything else. One thing I have noticed my machine shows the new RW6 project icons on the desktop as completely white - am guessing that they should be coloured in some way - or have some graphic - might be a clue.

The plugins all look uptodate etc - ones used in projects I have opened are: Stacks 3.0.2 , Sitemap Plus 2.90.13 and Pluskit 2.92.2. Have also tried on several projects using a variety of themes including Joe’s Foundation and all the same so don’t think Themes and plugins are causing this.

Any suggestions?

George


(Nik Fletcher) #4

This may be of interest: http://osxdaily.com/2015/02/21/fix-error-code-36-finder-mac-os-x/

—N


(George Peacock) #5

Nik

We know about the error -36 issue re OSX. We tried it as soon as this problem came up and it does not seem to solve the issue.

The problem is Rapidweaver RW6 - at least for us - is producing files/sandwiches that OSX has problems with. When looking for hidden files etc cant actually see any being created within the sandwich itself. The problem happens however as soon as we open a project in RW6 that was created with RW5. The dot_clean when applied to the sandwich makes no difference at all, the file still delivers an error36 when you try to move it and it displays on the desktop with pure white icon.

Something is wrong. Have upgraded to 6.3.6, Still same issue - basically RW6 is messing up files created with RW5.
Would really appreciate some help - happy to send sample files over etc.

George


(Nik Fletcher) #6

Could you try this with a new RW6 project (i.e. one that hasn’t been upgraded from RW5)? A .rw6 project is almost entirely the same as a .rwsw (the only real change is how the data is encoding within a PLIST file).

If it’s a change in the upgraded file, please drop us a note - support@realmacsoftware.com with the RW5 project, and we’ll be able to take a look.

—N


(George Peacock) #7

Nik

As advised earlier on - it seems only to be happening with projects upgraded from RW5 to 6.
Will send over a typical RW5 project as requested and see what you guys can make of it.

In RW 5 status of plugins as follows: Pluskit 2.92.2, Sitemap Plus 2.90.13, Stacks 2.7.2. I do have a few others but these are the ones I am using with current projects.

Thanks for looking into.

George


(Nik Fletcher) #8

Thanks, received the projects and looking into it. I’ve run a diff on the two projects, and the only changes made in the upgrade process are to the content within some PLIST files. So I’m unsure why that would cause problems. Investigations are ongoing.


(George Peacock) #9

Thanks Nik. It does seem a strange issue. I took a lot of care to try and make sure everything was updated and in line with the upgrade instructions.
Am starting to get used to RW6 but would be really good to be able to use it with our old files. Currently we are maintaining all previous work in RW5 given this issue.
Appreciate your help. If we can supply anything else just let me know. George


(George Peacock) #10

Just to say we are still v interested in getting a resolution to this. Issue has expanded somewhat in that a brand new project we started initially seemed to save fine but has now gone the same way as the files that were upgraded from RW5. Basically icon changed to pure white after a save and we got same error 36 when trying to move file to our server.

Can you advise what is happening - If no progress/view etc, I will try asking round the forum to see if anyone else had same issue and perhaps they managed to resolve. Clearly though hoping you guys can identify issue and fix.


(George Peacock) #11

Nik any progress or news on this issue. We are finding it is happening now with old and ew projects. Strangely the new ones start off as being OK then seems to go funny i.e icon changes to pure white and we get the error 36 if we try to move it to the server. Does not seem to coincide with adding anything particular by way of stacks or plugins etc.

We have never had this with any other application. We are running OSX 10.10.5 on a fairly new mac mini with lots of ram.


(Nik Fletcher) #12

Could you try turning off Quick Look in the RapidWeaver preferences, and save your project again? I believe it may be related to:

http://forums.realmacsoftware.com/t/file-creation-dates-missing/4464

—N


(Mike Bernard) #13

Yes, as expected turning off Quick Look in the preferences fixes the problem since the Quick look files are then no longer saved in the RW6 project file.

Will this bug be fixed?


(Nik Fletcher) #14

We are indeed looking into this, and we’ll be looking to include it in a future (likely the very next) update.

Thanks for bringing it to our attention.


(George Peacock) #15

Have tried turning off Quick look and in the two projects we are working with on RW6 sicne the upgrade both still have an error 36 when trying to move them to server filestore:

The Finder can’t complete the operation because some data in “JB1R_Home ver1.0.8” can’t be read or written.
(Error code -36)

However do note we no longer have a pure white icon and now get a more colourful purple one - which is an improvement. But the core problem remains.

Is there anything else we can do?

George


(Gabrielle Vickery) #16

Hi there, I’m also having the same problems trying to copy my rapidweaver documents from one mac to another, I get the code 36 error. I’ve upgraded to the latest Rapidweaver but it’s still happening. Is that fix still to come?


(Nik Fletcher) #17

Hi Gabrielle

Sorry to hear this: could we get a copy of your project file? support@realmacsoftware.com

Cheers,

—Nik


(Gabrielle Vickery) #18

It seems to be happening with several of my rapidweaver projects at the moment. However if I zip the file then I’m able to copy over successfully. I’ll try to get one over to you tomorrow.