Problems using FormLoom4 with RW 8.1.4

I can’t even preview FormLoom 4 pages under RW 8.1.4
It’s producing the enclosed error message.
Has anyone observed a similar behaviour?

If I set the FormLoom pages to draft the problem disappears. Furthermore I rebuilt one of the pages from scratch with FormLoom 4 and it worked fine. Before I do this with all other forms I would like to be sure that it is not a singular problem with my project.

Yabdab support couldn’t help me and asked me to contact RW support.

So, you are saying this started when install the the BETA copy of RapidWeaver 8.1.4 ?

I asked the same thing in the support ticket you sent me.

I am not sure how posting to the forums would garner a different response?

Have you tried downgrading to a stable version of RapidWeaver, like 8.1.0 ?

No, it started with RW 8.1 and was the same with every version through to RW 8.1.4 b. Therefore I stay with RW 8.03.

I just want to explore whether it’s my individual problem or others experience the same. If it’s only my problem, I will just invest a bit of time to rebuild my forms. As I already wrote you directly, some of them are obsolete anyway. So it’s not that much work to solve my individual problem. But if it’s a general one…

A 10 second search of the forum for ‘NSInvalid’ would have shown you that a fair number of users experienced the same and the fix is to get the update to the PlusKit plugin.

I am using latest beta on Mojave and have no issues? What Mac OS are you using?

There is no PlusKit plug-in here. I didn’t know that I need to install it to use FormLoom.

I am using 10.13.6.
If no one else experiences this problem, please forget about it.

@Prodrive You do NOT need PlusKit to use FormLoom. The problem occurs if you have an older version of PlusKit in your plugins folder. It doesn’t matter whether you are using it on a page, it does matter if you simply have it in the plugins folder. So check if you do. If yes, and you don’t need it ever, then delete it. If you need it for other things then upgrade.

It’s always possible you did something like download a free demo version of PlusKit awhile ago and have never used it and forgot about it.

Thank you all for your comments.
I checked that there was no PlusKit extension there.
Then I downloaded the latest version, installed it. No change.
Now I removed it again – also no change.

As i wrote before, I will delete my obsolete FormLoom4 pages and rebuild the one or two I still need. This solves the problem for me, and I hope nobody else stumbles upon it.

1 Like

I have the same issue using all versions of rapidweaver 8.1 since realease. Currently on 8.1.3. Existing projects using formloom 4 result in the problem when opening. New projects, where the forms are created from scratch, do not.

Could this be a problem with forms originally created with versions prior to FormLoom 4?

I cannot remember if these were converted or if I had to create them new with FormLoom 4. But Yabdab should know.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.