Problems with FTPS-TLS connection

Dear all,
My internet provider has just changed its FTP protocol, now FTPS-TLS see https://assistance.orange.fr/ordinateurs-peripheriques/installer-et-utiliser/un-service-d-orange/les-services-de-communication/pages-perso/pages-perso-sans-assistant/pages-perso-publier-votre-site-avec-un-logiciel-ftp_131783-144774
my problem is that I cannot configure the publishing parameters of RW to be able to publish again my website. I’ve read the previous posts on this topic, which appear to be too vague or confusing.
Does anyone have the solution, and would show me which parameters enter?
best,
ph

Sorry, the link above is in French and I’m on mobile so translation isn’t easily available.

What exactly are the parameters you can’t configure?

dear Doug,
Here are the settings I used (I also tried many other options without success, in brackets below, some changed for privacy):

-Publishing method: FTPS

  • Server: perso-ftp.orange.fr[:21]
  • Connections: Slowest
  • user name: my_user_name
  • password: my_password
  • website address: the_actual_http_address_of_the_site
  • mode: passive [Extended passive]
  • backup frequency: Never
  • no .htaccess File edited

One error message when Test button is clicked which is often appearing is "couldn’t sign in to your FTP server: Problem with the SSL CA cert (path? access rights?).

can you help me, likely in checking the requirements in the French page already sent?
best,
ph

Not sure how much help I’ll be, I don’t use FTPS myself.

I did take a look at the translation of the page above, it seems they’ve got a pretty good step by step instructions for using FileZilla including downloading it.

I don’t know if you’ve tried that yet, but that’s probably what I’d do first. FTPS often has issues with firewalls as it uses two ports. With FTPS, there are several different modes that web hosts can use to authenticate you.

So here’s what I’d do

  • save the current publishing settings in RW as a bookmark
  • setup publishing to go to a local folder, select a new folder (maybe on the desktop or within your documents folder)
  • publish your RapidWeaver project to that new folder
  • download and install FileZilla (the article above has a link)
  • go through the step by step instructions for publishing the site (just published from RW in the new folder) with FileZilla, if you have problems your hosting company will be able to help you, they should be very familiar with FileZilla.

That should get you published Pretty quickly and make sure that there’s no firewall or hosting issues.

Then I’d start trying to get RW publishing working.

dear Doug,

Of course, I’m using this solution but this is only a workaround (exporting as HTML then using another FTP client to upload the HTML files).
My question was about the proper settings of RW in order to directly upload the files by pushing the “Publish” button in RW. Since RW is pretty costly that’s a pity that it doesn’t work correctly…
Does anyone have a better solution?
thx & best,
ph

I don’t know how you’d expect me or anyone else to know that you have the workaround solution working. You never shared that in any of the previous posts, or shown any Screenshots of what settings you are using with FileZilla.

Costly is a matter of opinion, my “go to” ftp app (Transmit) is about 60% of the cost of RapidWeaver and all it does is publish. As for working correctly it does for thousands of users.

At this point I were you I’d probably follow the instructions in this article about resolving publishing issues including the steps about getting the log files and sending them to RealMac support.

dear Doug,
sincerely thx for your reply, that intended to be helpful! I was looking for internal solutions and that wasn’t so clear in my first post.
RW seems to have some problems with TLS and I’ll send the log files to RealMac support, good idea!
best,
ph

Hello all,

I’ve having this problem again. I had it back in June.

What can I do so I can publish my site changes?

Are you able to connect with a standalone FTP app like transmit or Filezilla?

If not, then it’s a real hosting issue.

If you can connect with the FTP app, then you can publish to a local folder and use the FTP app to copy the files to the server.

I can publish without any problems Neall. MacHighway’s hosting seems to be okay for me at least…

1 Like

I can connect with Cyberduck. I’m working with MacHighway. I may send them to this thread with my next reply.