Problems with german umlaute in Elixir Tesla Pro


(Hans Georg Britz-Mauch) #1

Hi,

first of all I wish you a happy new year.

i built a site with elixir Tesla Pro.

In the preview mode and in Safari the site looks well, but with Firefox the german Umlaute are not shown as they should.

ö is fine
ü is shown as u ̈

You find the page here:
LINK

And here is an image of the problem in Firefox.
You see the ö is looking as it should (marked green), but the ü …

Thank you for your help.

Regards
HG


(Brad Halstead) #2

@HGBM

Personally, I think this to be a bug in Firefox (43.0.3 for me), report it to them that their encoding is messed up. I am a man so I may be wrong lol

The source code looks proper but the translation to viewed html is not hence why I think it to be a browser issue.

Brad


(Adam Shiver) #3

I gave it a look in Firefox v34.0.5 and it looks great (http://d.pr/i/1hJP2). Updated to Firefox v42.0.0 and it also seems to be working OK here (http://d.pr/i/123Sw). I’m not sure what v43.0.3 is as I can’t seem to get Firefox to update to anything newer than 42.0.0. Is 43 a beta version?

Looking like some sort of encoding problem with FF though as @Turtle points out.


(Brad Halstead) #4

@Elixir, yeah, I had the same issue from FF 42, 43 is public release, had to go to their site and download it manually for some reason.

Brad


(Adam Shiver) #5

Interesting. Downloaded and installed 43.0.3 from their site since the updater didn’t pick that one up. Loaded up the site again and I still get the correct umlauts: http://d.pr/i/Q41m


(Brad Halstead) #6

Weird @Elixir, mine shows exactly as the op’s image but source code shows properly.

Brad


(Adam Shiver) #7

It does seem odd, but I don’t think it has to do with the theme. If @HGBM wants to send me his project file I’ll take a quick look.


(Hans Georg Britz-Mauch) #8

Hi everybody,
I have the same problem with Firefox 24ESR. Other sites using the german umlaute are looking fine, here is an example.

The site is built with RW6 and Foundation.

I also changed the theme to Open (Nick Cates Design):

You find the site here: CLICK

Everything works fine. So there should be a solution for this problem.


(Peter Danckwerts) #9

Could it possibly a font problem? If Firefox was relying on a non-unicode font (or a unicode font which was in some way defective) for the page created in Tesla but not for the pages created in other themes, this could cause it to display some characters wrongly.


(Hans Georg Britz-Mauch) #10

@ peterdanckwerts: Thank you, seems that you are right.

When I change the font to “Open Sans font” the umlaute are shown in another way, but still not correct.

@ Adam: Are there only two fonts? Can I use a font like Times or Helvetica?


(Robert Ziebol 🖖🏼) #11

This could also be a host issue. I can not remember the exact reasons why, but we have had a few tickets about this and it always came down to something the host had to either switch or turn on. I will try to do a search of our old tickets and find out what.

Edit - wow, ok, a ton of tickets came up, going to be a while, not sure if I will get this done or not.


(Peter Danckwerts) #12

I think there a setting on some hosts which interferes with fonts hosted on other domains. I self-host where fonts possible.


(Michael M.) #13

Hi HG,

I had similar problems (not with the Tesla theme) some time before. It was caused by a PHP configuration on the server. In one case it was a Strato server which supports a special PHP acceleration, whatever that was (even the hoster couldn’t give me information what this is). I had to remove the PHP acceleration. In another case it was the PHP version, I had to go back to an earlier version.

Perhaps checking the PHP configuration is a starting point for fixing that issue.


(Hans Georg Britz-Mauch) #14

Hi,
I solved the problem.

I recognized, that on the page “Impressum” all umlaute are shown correct, also the ü. So I wonder why this could be. Than I remembered, that I copied the text for the page “Grusswort” from a MS Word-document. After I overwrites the words containing an ü in the text stack and transmitted the page again on the server, everythings working fine now.

Thank you for your help.

Best wishes
HG


(Adam Shiver) #15

@HGBM: Glad it was a super easy fix! Copying and pasting can be problematic when doing so from a Word doc or a website. All that extra formatting that the app or site already have on the text carries over. Best thing to do often is to retype the text, or use RapidWeaver’s wonderful Paste As Plain Text feature in the Edit menu. This solves most problems like this. Though who knows with Word, right? It does some weird things to text sometimes. But generally this should strip off that excess formatting, though if Word is just using a different character it may not work.

Anyway, glad you got all sorted out!