Project could not be opened


(Maxime) #1

Hello,

Sorry for my english, I’m french.

I have a RapidWeaver Project (my website http://charlielamare.com ) and I have a big problem with my .rw6 file. Now, when I want to open it to add photos, RapidWeaver tells me “charlielamare.rw6 could not be opened”. I have some saves of this file on my mac (Time Capsule and Carbon Copy Cloner) but no files works… I can’t open my website project, I have many and many hours of working on it and I’m feared to lost all.
Do you have solution to repair this file or try to re-make a rw6 file with my FTP. (I have all access of files in my FTP).

Thanks a lot in advance.


#2

Some questions and things to check…

What version of RW6 ?
Did you recently upgrade RW and if so, did it stop working after the update ?
Are you running RW by double-clicking on the project file ?
Did you try downloading the latest version of RW (6.3.4) ?
Did you check permissions on the project file ?


(Maxime) #3

Thanks for your reply.

I have the last version of RW6 now. But I have make this website on January I think. (with older version but 6 not 5)
I make all upgrade when there are available. But I have tried with an older version and it’s the same.
Open in RW6, double clicking… I have tried all possibilities.
Permissions are OK read and write to me (admin) and all users.


(Martin Waring) #4

I have a similar problem, I think. I try opening older projects in RW6.3.4 either by double clicking the project file or by opening it from within RW. Either way the project won’t open and RW crashes. I also have stacks 3 recently installed.
Last night I did a right click on the project file and opened it with the oldest version of RW6 I have which is 6.0 and it worked without crashing. I was then able to make changes, save the project file, re-open it in 6.3.4 and then publish it successfully. I have no idea why this might work but give it a try.


(Maxime) #5

I have downloaded RW 6.0 but same result. Like you, sometime there is “could not be opened”, sometime it crashes.

Is there a solution to re-build RW6 file with FTP content ?


(Martin Waring) #6

That’s a shame. You could also try re-booting your Mac after installing 6.0 and try again. Try both from the project file and ‘Open With’ and from within RW as well. If it does open save it immediately. After that I’m afraid I don’t have any more suggestions. Good luck.


(Oscar Schmid) #7

@Maxoo
Unfortunately not possible.

Try this. Make a copy of your file in the finder.
Perhaps, the copy can be opened.


(Maxime) #8

Already tried. And I have some copy in Time Machine and Carbon Copy Cloner.
Maybe can I send you my RW6 file. Someone can try to open it ?


(Oscar Schmid) #9

@Maxoo

But to create a copy in finder is different from the copy of Time Machine (maybe corrupt).

You can send it to me or leave them ready to the dropbox etc…
But a zip-file. Do not know if it’s possible by email.
maybe you can attach the file in the Forum here.

You have a personal message with my mail address.


(Maxime) #10

Same result when I create a copy.
Thanks, I upload it on my server and send you link asap.


(Oscar Schmid) #11

Can you create and save an new RW file?
Then, can you re-open this file?


(Maxime) #12

Yes, no problem to create, modify, save and re-open new project.
I have send you link of my corrupted rw6 in personal message.


(Oscar Schmid) #13

@Maxoo

Sorry.
I cannot open your RW file. My RW 6 crashes, all versions, and my computer crashes too.

I think, your RW file is too big. RW cannot work with such files, 728.2 MB !
You have all your photo-files in the project. Better, when you warehouse your images, not in the RW file, only linked.
Look the size of my projects.
Perhaps, the Realmac team can repair your file. Send your RW file-link to the Realmac team.




(Maxime) #14

I have opened the packet (right clic on file) and deleted all photos but with only 39mo it could not be opened yet :(.
I will try to send at RW team.

Thanks a lot for your help.


(Oscar Schmid) #15

@Maxoo
My pleasure.
I had the same idea. However, this has brought nothing and the size of the file had not changed.
I don’t know why!


(Rogelio Meza Torres) #16

Hi!
I’ve had this very same problem: I’ve been using two different Computers working on my project. The project is placed in a folder in Dropbox. I thought this was the reason for the “could not be open…” problem.
Tried this: Copied the file project to the finder, Right-clic on and select “show contents” option. Then I saw two “contents.plist” files (one of them a conflicted copy). Deleted the copy.
Inside the “pages” folder saw another two files in conflict (same name "contents.plist) and deleted de copy too.
After that, I was able to the project. Loose a few lines of code, but my project was fine.
Hope you can find this useful.