Data is not in the right format

I have an old website made with RapidWeaver that I need to change from version 7 to version 8.

I’ve tried to open it thru RapidWeaver 8 and also tried to double click the RW file.

All that happens is I get the message:
The document ‘x’ could not be opened. The data is not in the correct format.

How can I open it??
Thank you!

Does it still open in RW7?

1 Like

Oh shoot, I have RW7 so this file must be RW6?
Sorry about that confusion.
Do you have any ideas??
It won’t open with RW7.

RapidWeaver 6 project files should be able to open with RW7. Could it be an RW 5 file? How old of a website is it? What is the file extension?

1 Like

Removed wrong content

Removed, wrong content

Oh teefers
I was wrong, the correct file I am trying to open is called
Last opened on Nov 2, 2105
But… It says it was modified aug 18, 2018??
That makes no sense…

Maybe modified, meaning moved to a different spot??

from the file extension(rw) and the date I would guess its a rapidweaver 7 project. Do you have a backup (like time machine)?

No, I’m looking at the site, and yes I did update the site last year

Noooo :frowning: I don’t think so…
Would timemachine work if I have moved the file?

Time Machine (left running) will backup everything, if you move a file you would have to find it at the old location. It will backup incrementally until you run out of backup space, then it deletes the oldest stuff first.

But if you’re not running it no point looking for it.
You really need to adopt some sort of backup strategy, so in the future, you can recover easily. Time machine works very well and is included with MacOS, all you need is an external drive (pretty cheap nowadays).

It sounds like the project file may be corrupt. If that’s the only copy that means you may have to rebuild it from the existing site. Now if it was a RapidWeaver 7 (or greater) project, there was an option to “backup” the project file to the server when you publish. If you had that option turned on in the publishing settings it might have been backed up for you.
If you think you may have turned that option on then check on the server (host company) for a folder(directory) that will have a strange looking name like


Ending with _rwbackup

If that is found then you can recover from that.


Thank you very very much teefers!
I will work on this…
Thank you for your help and direction!

1 Like

Hey teefers,
It looks like I have to remake it.

Do you have any suggestions or tools to make the process a little less painful.

I don’t mind the copy and pasting of the content.
I am more dreading trying to get the Pages in the right order, title names, page names…

Any tips would sure be appreciated.
Thank you again!

Can we see the site…url…it might help

1 Like
It is a mess, and I have to fix it. :wink:

I’m drawing a blank on the name of the product that will download a published site. It won’t make it into an RW project but could help.

1 Like

You do have a sitemap page!


Sitesucker is what I was thinking off:

Not sure how much it will help but would at least get images etc back to the Mac.


Oh yeah! Site Map!! That is a great idea!! Thank you!!