Project Theme is Missing Null Theme no file .rw


(donatello) #1

Hello everybody,

I read many threads and I could not find any solutions. My problems is something that already happened to several users.

I cannot open my file-project anymore. The message which pops up says:“The (null) theme that this document uses is missing…”. My theme is foundation-stack

I learned that being on iCloud something might go wrongly and now my file is corrupted. I tried to follow some suggestion but it did not work out.

I opened in finder the file clicking on show package contents but I could not find a file .rw, but I could see a file contents.plist

Besides, I checked right now also other websites built and in show package contents I could not find a file .rw. At least I can still open these projects.

What can I do it? is there anybody who could help me out? it would be a disaster to rebuild again the whole website.

Thank you so much.

Donatello Masellis
54%20AM


(Doug Bennett) #2

Assuming you tried apply theme and open.

Might have a look at this post:


(donatello) #3

Dear Bennet, I am going to read it right away.

I tried it but on contents.plist files are named correctly. nothing strange about them.

thank you so much for trying to help me out but it did not work out.

Donatello Masellis


(Cris Baker) #4

I’ve just solved a not dissimilar problem by ensuring that CSS files are NOT consolidated [in Settings>Advanced], Marking All Pages and Resources as Changed [in Menu>File] and then publishing the page. Might be worth a try…

warm regards, Cris


(donatello) #5

Sorry Cris, where is there [Settings>advanced]?
I cannot open the project.In order to "Marking all Pages and Resources as Changed [in Menu>File] I have to open the project but I cannot.

Best Regards
Donatello


(Cris Baker) #6

You need to have opened the project to clicks on the Settings icon to go to Advanced.

When I tried to open my project RW also said it couldn’t find the theme, so I opened it anyway with the suggested default theme and then changed the theme using Menu > View >Show Themes.

I always save as another name so the original project file is unchanged so I can have another try if it doesn’t work…


(donatello) #7

Hi Cris, sorry for reply only today but I have been busy for other projects.
Right, that is my problem. I cannot open it.
I guess there is not any solution about that.
In my case, at the end I have found a backup copy, (actually I was lucky because I have had another macbook with my iCloud id and my father by chance last week run it and using the cloud buck up was done) and I lost only 3 days. Better than the whole project.
My suggestion is to remember to everybody that an iCloud back up is not safe. if something goes wrong during the synchronization, there is a big possibility to have a corrupted file that cannot be opened any more.
IN case there might be a solution, I suggest to let pend this topic. otherwise it might be closed.

best regards

donatello